bloc_base 0.1.0

flutter bloc base

0
likes
30 / 110
pub points
51 %
popularity

We analyzed this package on Sep 19, 2020, and awarded it 30 pub points (of a possible 110):

Follow Dart file conventions
10 / 20

0/10 points: Provide a valid pubspec.yaml

The package description is too short.

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
10 / 20

0/10 points: Package has an example

No example found.

See package layout guidelines on how to add an example.

10/10 points: 20% or more of the public API has dartdoc comments

  • 9 out of 20 API elements (45.0 %) have documentation comments.
Support multiple platforms
0 / 20

0/20 points: Supports 0 of 2 possible platforms (native, js)

Consider supporting multiple platforms:

Tag detection failed.

Could not resolve import: package:meta/meta.dart

Pass static analysis
0 / 30

0/30 points: code has no errors, warnings, lints, or formatting issues

Found 3 issues. Showing the first 2:

ERROR: Target of URI doesn't exist: 'package:meta/meta.dart'.

lib/src/bloc_event_state.dart:5:8

  ╷
5 │ import 'package:meta/meta.dart';
  │        ^^^^^^^^^^^^^^^^^^^^^^^^
  ╵

To reproduce make sure you are using pedantic and run dartanalyzer lib/src/bloc_event_state.dart

ERROR: Undefined name 'required' used as an annotation.

lib/src/bloc_event_state.dart:63:23

   ╷
63 │   EventStateBaseBloc({@required this.initialState}) {
   │                       ^^^^^^^^^
   ╵

To reproduce make sure you are using pedantic and run dartanalyzer lib/src/bloc_event_state.dart

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
rxdart^0.21.00.21.00.24.1

To reproduce run pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^0.21.0` on rxdart does not support the latest published version `0.24.1`

pubspec.yaml:11:11

   ╷
11 │   rxdart: ^0.21.0
   │           ^^^^^^^
   ╵

10/10 points: Package supports latest stable Dart and Flutter SDKs