bloc_base 0.1.0

  • Readme
  • Changelog
  • Installing
  • 45

bloc_base #

A new Flutter package project.

Getting Started #

This project is a starting point for a Dart package, a library module containing code that can be shared easily across multiple Flutter or Dart projects.

For help getting started with Flutter, view our online documentation, which offers tutorials, samples, guidance on mobile development, and a full API reference.

[ 0.1.0] - 2019-05-03

Initial release

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:

  bloc_base: ^0.1.0

2. Install it

You can install packages from the command line:

with pub:

$ pub get

with Flutter:

$ flutter pub get

Alternatively, your editor might support pub get or flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:

import 'package:bloc_base/bloc_base.dart';
Describes how popular the package is relative to other packages. [more]
Code health derived from static analysis. [more]
Reflects how tidy and up-to-date the package is. [more]
Weighted score of the above. [more]
Learn more about scoring.

We analyzed this package on Jan 16, 2020, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.7.0
  • pana: 0.13.4

Health issues and suggestions

Fix lib/src/bloc_event_state.dart. (-43.75 points)

Analysis of lib/src/bloc_event_state.dart failed with 2 errors:

line 5 col 8: Target of URI doesn't exist: 'package:meta/meta.dart'.

line 63 col 23: Undefined name 'required' used as an annotation.

Fix lib/src/validators.dart. (-0.50 points)

Analysis of lib/src/validators.dart reported 1 hint:

line 13 col 29: Unnecessary new keyword.

Format lib/bloc_base.dart.

Run dartfmt to format lib/bloc_base.dart.

Fix additional 4 files with analysis or formatting issues.

Additional issues in the following files:

  • lib/src/base_bloc.dart (Run dartfmt to format lib/src/base_bloc.dart.)
  • lib/src/bloc_event.dart (Run dartfmt to format lib/src/bloc_event.dart.)
  • lib/src/bloc_state.dart (Run dartfmt to format lib/src/bloc_state.dart.)
  • lib/src/resource.dart (Run dartfmt to format lib/src/resource.dart.)

Maintenance issues and suggestions

Support latest dependencies. (-10 points)

The version constraint in pubspec.yaml does not support the latest published versions for 1 dependency (rxdart).

The package description is too short. (-20 points)

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

Maintain an example. (-10 points)

Create a short demo in the example/ directory to show how to use this package.

Common filename patterns include main.dart, example.dart, and bloc_base.dart. Packages with multiple examples should provide example/

For more information see the pub package layout conventions.


Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.1.0 <3.0.0
rxdart ^0.21.0 0.21.0 0.23.1
Dev dependencies
test ^1.0.0