bitnob 0.1.1 copy "bitnob: ^0.1.1" to clipboard
bitnob: ^0.1.1 copied to clipboard

Bitnob SDK equips online businesses using flutter with the ability to integrate our API features easily.

5
likes
140/ 160
pub points
14%
popularity

We analyzed this package 4 days ago, and awarded it 140 pub points (of a possible 160):

OK
Follow Dart file conventions
30 / 30trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: MIT.

OK
Provide documentation
20 / 20trigger folding of the section

10/10 points: 20% or more of the public API has dartdoc comments

5 out of 8 API elements (62.5 %) have documentation comments.

Some symbols that are missing documentation: bitnob, bitnob.Mode, bitnob.Mode.Mode.

10/10 points: Package has an example

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 2 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS

These platforms are not supported:

Package does not support platform `Windows`.

Because:

  • package:bitnob/bitnob.dart that imports:
  • package:bitnob/src/screens/preview.dart that imports:
  • package:webview_flutter/webview_flutter.dart that declares support for platforms: Android, iOS.
Package does not support platform `Linux`.

Because:

  • package:bitnob/bitnob.dart that imports:
  • package:bitnob/src/screens/preview.dart that imports:
  • package:webview_flutter/webview_flutter.dart that declares support for platforms: Android, iOS.
Package does not support platform `macOS`.

Because:

  • package:bitnob/bitnob.dart that imports:
  • package:bitnob/src/screens/preview.dart that imports:
  • package:webview_flutter/webview_flutter.dart that declares support for platforms: Android, iOS.
Package does not support platform `Web`.

Because:

  • package:bitnob/bitnob.dart that imports:
  • package:bitnob/src/screens/preview.dart that imports:
  • package:webview_flutter/webview_flutter.dart that declares support for platforms: Android, iOS.

These issues are present but do not affect the score, because they may not originate in your package:

Package does not support platform `Android`.

Because:

  • package:bitnob/bitnob.dart that imports:
  • package:bitnob/src/screens/preview.dart that imports:
  • package:webview_flutter/webview_flutter.dart that imports:
  • package:webview_flutter/src/webview.dart that imports:
  • package:webview_flutter_wkwebview/webview_flutter_wkwebview.dart that declares support for platforms: iOS.
Package does not support platform `iOS`.

Because:

  • package:bitnob/bitnob.dart that imports:
  • package:bitnob/src/screens/preview.dart that imports:
  • package:webview_flutter/webview_flutter.dart that imports:
  • package:webview_flutter/src/webview.dart that imports:
  • package:webview_flutter_android/webview_surface_android.dart that declares support for platforms: Android.
partial
Pass static analysis
40 / 50trigger folding of the section

40/50 points: code has no errors, warnings, lints, or formatting issues

lib/bitnob.dart doesn't match the Dart formatter.

To format your files run: dart format .

failed
Support up-to-date dependencies
30 / 40trigger folding of the section

0/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
dio ^4.0.6 4.0.6 5.4.3+1
flutter flutter 0.0.0 0.0.0
webview_flutter ^3.0.4 3.0.4 4.8.0
Transitive dependencies
Package Constraint Compatible Latest
characters - 1.3.0 1.3.0
collection - 1.18.0 1.19.0
http_parser - 4.0.2 4.1.0
material_color_utilities - 0.8.0 0.12.0
meta - 1.12.0 1.15.0
path - 1.9.0 1.9.0
plugin_platform_interface - 2.1.8 2.1.8
sky_engine - 0.0.99 0.0.99
source_span - 1.10.0 1.10.0
string_scanner - 1.2.0 1.2.0
term_glyph - 1.2.1 1.2.1
typed_data - 1.3.2 1.3.2
vector_math - 2.1.4 2.1.4
webview_flutter_android - 2.10.4 3.16.4
webview_flutter_platform_interface - 1.9.5 2.10.0
webview_flutter_wkwebview - 2.9.5 3.13.1

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^4.0.6` on dio does not support the stable version `5.0.0`.

Try running dart pub upgrade --major-versions dio to update the constraint.

The constraint `^3.0.4` on webview_flutter does not support the stable version `4.0.0`.

Try running dart pub upgrade --major-versions webview_flutter to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

20/20 points: Compatible with dependency constraint lower bounds

pub downgrade does not expose any static analysis error.

Analyzed with Pana 0.22.7, Flutter 3.22.2, Dart 3.4.3.

Check the analysis log for details.

5
likes
140
pub points
14%
popularity

Publisher

verified publisherbitnob.com

Bitnob SDK equips online businesses using flutter with the ability to integrate our API features easily.

Repository (GitHub)
View/report issues

Documentation

API reference

License

MIT (LICENSE)

Dependencies

dio, flutter, webview_flutter

More

Packages that depend on bitnob