bird 0.0.3+5
bird: ^0.0.3+5 copied to clipboard

A Dart framework for writing Apps.

0
likes
65 / 130
pub points
45 %
popularity

We analyzed this package on May 14, 2021, and awarded it 65 pub points (of a possible 130):

Follow Dart file conventions
5 / 20

0/10 points: Provide a valid pubspec.yaml

Homepage URL doesn't exist.

At the time of the analysis https://www.github.com/modulovalue/bird was unreachable.

The package description is too short.

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

0/5 points: Provide a valid README.md

Links in `README.md` should be secure. 1 link is insecure.

README.md:13:49

   ╷
13 │ <p>Please file feature requests and bugs at the <a href="http://example.com/issues/replaceme">issue tracker</a>.</p>
   │                                                 ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
   ╵

Use https URLs instead.

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
10 / 20

0/10 points: Package has an example

No example found.

See package layout guidelines on how to add an example.

10/10 points: 20% or more of the public API has dartdoc comments

  • 413 out of 1916 API elements (21.6 %) have documentation comments.
Support multiple platforms
20 / 20

20/20 points: Supports 2 of 2 possible platforms (native, js)

Pass static analysis
20 / 30

20/30 points: code has no errors, warnings, lints, or formatting issues

Found 46 issues. Showing the first 2:

INFO: 'List' is deprecated and shouldn't be used. Use a list literal, [], or the List.filled constructor instead.

lib/src/layer1/smart_json/layer1/smartlistt.dart:211:23

    ╷
211 │     final charCodes = List<int>(length);
    │                       ^^^^^^^^^
    ╵

To reproduce make sure you are using pedantic and run dartanalyzer lib/src/layer1/smart_json/layer1/smartlistt.dart

lib/abstract_dart.dart is not formatted according to dartfmt

To format your files run: dartfmt -w .

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
abstract_dart^1.0.21.0.21.0.2
async^2.3.02.6.12.6.1
collection^1.14.111.15.01.15.0
crypto^2.1.32.1.53.0.1
dartz^0.9.0-dev.50.9.20.9.2
decimal^0.3.50.3.51.1.0
meta^1.0.01.3.01.3.0
pedantic^1.7.01.11.01.11.0
quiver^2.0.02.1.53.0.1
statemachine^1.6.01.6.23.1.0
trie^1.0.01.0.21.0.2
Transitive dependencies
PackageConstraintCompatibleLatest
charcode-1.2.01.2.0
convert-2.1.13.0.0
matcher-0.12.100.12.10
path-1.8.01.8.0
rational-0.3.81.1.0+1
typed_data-1.3.01.3.0

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

Found 4 issues. Showing the first 2:

The constraint `^2.1.3` on crypto does not support the stable version `3.0.0`.

Try running dart pub upgrade --major-versions crypto to update the constraint.

The constraint `^0.3.5` on decimal does not support the stable version `1.0.0`.

Try running dart pub upgrade --major-versions decimal to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Support sound null safety
0 / 20

0/20 points: Package does not opt in to null safety.

Package language version (indicated by the sdk constraint `>=2.6.0 <3.0.0`) is less than 2.12.

Consider migrating.

Analysed with Pana 0.16.0, Dart 2.12.4.

0
likes
65
pub points
45%
popularity

Publisher

modulovalue.com

A Dart framework for writing Apps.

Homepage

Documentation

API reference

License

BSD (LICENSE)

Dependencies

abstract_dart, async, collection, crypto, dartz, decimal, meta, pedantic, quiver, statemachine, trie

More

Packages that depend on bird