bip32_dart 1.0.5
bip32_dart: ^1.0.5 copied to clipboard

Dart native js
Flutter Android iOS Linux macOS web Windows

A BIP32 (https://github.com/bitcoin/bips/blob/master/bip-0032.mediawiki) compatible library for Flutter writing by Dart.

0
likes
70 / 110
pub points
40 %
popularity

We analyzed this package on Mar 1, 2021, and awarded it 70 pub points (of a possible 110):

Follow Dart file conventions
20 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
0 / 20

0/10 points: Package has an example

No example found.

See package layout guidelines on how to add an example.

0/10 points: 20% or more of the public API has dartdoc comments

  • 2 out of 45 API elements (4.4 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

Support multiple platforms
20 / 20

20/20 points: Supports 2 of 2 possible platforms (native, js)

Pass static analysis
20 / 30

20/30 points: code has no errors, warnings, lints, or formatting issues

Found 63 issues. Showing the first 2:

INFO: Unnecessary new keyword.

lib/src/bip32_base.dart:21:18

   ╷
21 │   final _BITCOIN = new NetworkType(
   │ ┌──────────────────^
22 │ │   wif: 0x80,
23 │ │   bip32: new Bip32Type(
24 │ │     public: 0x0488b21e,
25 │ │     private: 0x0488ade4
26 │ │   )
27 │ │ );
   │ └─^
   ╵

To reproduce make sure you are using pedantic and run dartanalyzer lib/src/bip32_base.dart

INFO: Unnecessary new keyword.

lib/src/bip32_base.dart:23:10

   ╷
23 │     bip32: new Bip32Type(
   │ ┌──────────^
24 │ │     public: 0x0488b21e,
25 │ │     private: 0x0488ade4
26 │ └   )
   ╵

To reproduce make sure you are using pedantic and run dartanalyzer lib/src/bip32_base.dart

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
bs58check^1.0.11.0.11.0.1
hex^0.1.20.1.20.1.2
pointycastle^1.0.21.0.22.0.1
Transitive dependencies
PackageConstraintCompatibleLatest
charcode-1.1.31.2.0
collection-1.14.131.15.0
convert-2.1.13.0.0
crypto-2.1.53.0.0
typed_data-1.2.01.3.0

To reproduce run pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^1.0.2` on pointycastle does not support the latest published version `2.0.1`

pubspec.yaml:10:17

   ╷
10 │   pointycastle: ^1.0.2
   │                 ^^^^^^
   ╵

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analysed with Pana 0.14.10, Dart 2.10.5.

0
likes
70
pub points
40%
popularity

A BIP32 (https://github.com/bitcoin/bips/blob/master/bip-0032.mediawiki) compatible library for Flutter writing by Dart.

Homepage

Documentation

API reference

Uploader

prapat@prachakij.com

License

MIT (LICENSE)

Dependencies

bs58check, hex, pointycastle

More

Packages that depend on bip32_dart