battle_net 0.1.3+2 copy "battle_net: ^0.1.3+2" to clipboard
battle_net: ^0.1.3+2 copied to clipboard

Dart wrapper client for Battle.Net API https://develop.battle.net/documentation

0
likes
140/ 140
pub points
11%
popularity

We analyzed this package 6 days ago, and awarded it 140 pub points (of a possible 140):

partial
Follow Dart file conventions
30 / 30trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

Issue tracker URL doesn't exist.

At the time of the analysis https://github.com/vmpay/battle_net_dart/issues was unreachable. Make sure that the website is reachable via HEAD requests.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: MIT.

OK
Provide documentation
20 / 20trigger folding of the section

10/10 points: 20% or more of the public API has dartdoc comments

38 out of 110 API elements (34.5 %) have documentation comments.

Some symbols that are missing documentation: battle_net.AuthorizationCodeResponse.accessToken, battle_net.AuthorizationCodeResponse.copyWith, battle_net.AuthorizationCodeResponse.expiresIn, battle_net.AuthorizationCodeResponse.AuthorizationCodeResponse.fromJson, battle_net.AuthorizationCodeResponse.AuthorizationCodeResponse.fromRawJson.

10/10 points: Package has an example

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 6 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ Windows
  • ✓ Linux
  • ✓ macOS
  • ✓ Web
OK
Pass static analysis
50 / 50trigger folding of the section

50/50 points: code has no errors, warnings, lints, or formatting issues

OK
Support up-to-date dependencies
20 / 20trigger folding of the section

10/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
collection ^1.18.0 1.18.0 1.18.0
http ^1.1.2 1.2.1 1.2.1
meta ^1.10.0 1.14.0 1.14.0
Transitive dependencies
Package Constraint Compatible Latest
async - 2.11.0 2.11.0
http_parser - 4.0.2 4.0.2
path - 1.9.0 1.9.0
source_span - 1.10.0 1.10.0
string_scanner - 1.2.0 1.2.0
term_glyph - 1.2.1 1.2.1
typed_data - 1.3.2 1.3.2
web - 0.5.1 0.5.1

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analyzed with Pana 0.22.3, Dart 3.3.3.

Check the analysis log for details.

0
likes
140
pub points
11%
popularity

Publisher

verified publishervmpay.eu

Dart wrapper client for Battle.Net API https://develop.battle.net/documentation

Repository (GitHub)
View/report issues

Documentation

API reference

License

MIT (LICENSE)

Dependencies

collection, http, meta

More

Packages that depend on battle_net