basic_utils 3.0.2
basic_utils: ^3.0.2 copied to clipboard

Common util classes providing a solution for different situations.

133
likes
120 / 130
pub points
98 %
popularity

We analyzed this package on Apr 13, 2021, and awarded it 120 pub points (of a possible 130):

Follow Dart file conventions
20 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
20 / 20

10/10 points: Package has an example

  • Found example at: example/main.dart

10/10 points: 20% or more of the public API has dartdoc comments

  • 197 out of 392 API elements (50.3 %) have documentation comments.
Support multiple platforms
20 / 20

20/20 points: Supports 2 of 2 possible platforms (native, js)

Pass static analysis
20 / 30

20/30 points: code has no errors, warnings, lints, or formatting issues

Found 11 issues. Showing the first 2:

INFO: 'getSha1ThumbprintFromBytes' is deprecated and shouldn't be used. Use [getHash].

lib/src/X509Utils.dart:341:21

    ╷
341 │         CryptoUtils.getSha1ThumbprintFromBytes(pubKeySequence.encodedBytes!);
    │                     ^^^^^^^^^^^^^^^^^^^^^^^^^^
    ╵

To reproduce make sure you are using pedantic and run dartanalyzer lib/src/X509Utils.dart

INFO: 'getSha256ThumbprintFromBytes' is deprecated and shouldn't be used. Use [getHash].

lib/src/X509Utils.dart:343:21

    ╷
343 │         CryptoUtils.getSha256ThumbprintFromBytes(pubKeySequence.encodedBytes!);
    │                     ^^^^^^^^^^^^^^^^^^^^^^^^^^^^
    ╵

To reproduce make sure you are using pedantic and run dartanalyzer lib/src/X509Utils.dart

Support up-to-date dependencies
20 / 20

10/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
http^0.13.00.13.10.13.1
json_annotation^4.0.04.0.14.0.1
logging^1.0.01.0.11.0.1
pointycastle^3.0.0-nullsafety.23.0.13.0.1
Transitive dependencies
PackageConstraintCompatibleLatest
charcode-1.2.01.2.0
collection-1.15.01.15.0
http_parser-4.0.04.0.0
meta-1.3.01.3.0
path-1.8.01.8.0
source_span-1.8.11.8.1
string_scanner-1.1.01.1.0
term_glyph-1.2.01.2.0
typed_data-1.3.01.3.0

To reproduce run pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Support sound null safety
20 / 20

20/20 points: Package and dependencies are fully migrated to null safety!

Analysed with Pana 0.15.4, Dart 2.12.2.

133
likes
120
pub points
98%
popularity

Common util classes providing a solution for different situations.

Repository (GitHub)
View/report issues

Documentation

API reference

Uploader

aic7to@gmail.com

License

MIT (LICENSE)

Dependencies

http, json_annotation, logging, pointycastle

More

Packages that depend on basic_utils