base_flutter 0.0.1
base_flutter: ^0.0.1

Flutter Android iOS

A new flutter plugin project.

0
likes
60 / 110
pub points
0 %
popularity

We analyzed this package on Nov 24, 2020, and awarded it 60 pub points (of a possible 110):

Follow Dart file conventions
10 / 20

0/10 points: Provide a valid pubspec.yaml

The package description is too short.

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
10 / 20

0/10 points: Package has an example

No example found.

See package layout guidelines on how to add an example.

10/10 points: 20% or more of the public API has dartdoc comments

  • 27 out of 134 API elements (20.1 %) have documentation comments.
Support multiple platforms
10 / 20

10/20 points: Supports 2 of 3 possible platforms (iOS, Android, Web)

Found 6 issues. Showing the first 2:

Consider supporting multiple platforms:

Package does not support Flutter platform Web

Because:

  • package:base_flutter/base_flutter.dart that declares support for platforms: Android, iOS
Pass static analysis
20 / 30

20/30 points: code has no errors, warnings, lints, or formatting issues

Found 9 issues. Showing the first 2:

INFO: The exception variable 'e' isn't used, so the 'catch' clause can be removed.

lib/api/http_util.dart:148:34

    ╷
148 │     } on TimeoutException catch (e) {
    │                                  ^
    ╵

To reproduce make sure you are using pedantic and run flutter analyze lib/api/http_util.dart

lib/api/http_util.dart is not formatted according to dartfmt

To format your files run: dartfmt -w .

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
url_launcher^4.0.24.2.0+35.7.10
Transitive dependencies
PackageConstraintCompatibleLatest
characters-1.1.0-nullsafety.51.1.0-nullsafety.5
collection-1.15.0-nullsafety.51.15.0-nullsafety.5
meta-1.3.0-nullsafety.61.3.0-nullsafety.6
typed_data-1.3.0-nullsafety.51.3.0-nullsafety.5
vector_math-2.1.0-nullsafety.52.1.0-nullsafety.5

To reproduce run pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^4.0.2` on url_launcher does not support the latest published version `5.7.10`

pubspec.yaml:14:17

   ╷
14 │   url_launcher: ^4.0.2
   │                 ^^^^^^
   ╵

10/10 points: Package supports latest stable Dart and Flutter SDKs

0
likes
60
pub points
0%
popularity

A new flutter plugin project.

Homepage

Documentation

API reference

Uploader

lekhanhnhac@gmail.com

License

unknown (LICENSE)

Dependencies

flutter, url_launcher

More

Packages that depend on base_flutter