base_flutter 0.0.1

  • Readme
  • Changelog
  • Installing
  • 59

Introduction #

TODO: Give a short introduction of your project. Let this section explain the objectives or the motivation behind this project.

Getting Started #

TODO: Guide users through getting your code up and running on their own system. In this section you can talk about:

  1. Installation process
  2. Software dependencies
  3. Latest releases
  4. API references

Build and Test #

TODO: Describe and show how to build your code and run the tests.

Contribute #

TODO: Explain how other users and developers can contribute to make your code better.

If you want to learn more about creating good readme files then refer the following guidelines. You can also seek inspiration from the below readme files:

0.0.1 #

  • TODO: Describe initial release.

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  base_flutter: ^0.0.1

2. Install it

You can install packages from the command line:

with Flutter:


$ flutter pub get

Alternatively, your editor might support flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:base_flutter/base_flutter.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
39
Health:
Code health derived from static analysis. [more]
100
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
50
Overall:
Weighted score of the above. [more]
59
Learn more about scoring.

We analyzed this package on Jan 19, 2020, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.7.0
  • pana: 0.13.4
  • Flutter: 1.12.13+hotfix.5

Health suggestions

Fix lib/api/http_util.dart. (-0.50 points)

Analysis of lib/api/http_util.dart reported 1 hint:

line 148 col 34: The exception variable 'e' isn't used, so the 'catch' clause can be removed.

Format lib/base_flutter.dart.

Run flutter format to format lib/base_flutter.dart.

Format lib/common/config.dart.

Run flutter format to format lib/common/config.dart.

Fix additional 5 files with analysis or formatting issues.

Additional issues in the following files:

  • lib/common/shared.dart (Run flutter format to format lib/common/shared.dart.)
  • lib/model/config_info.dart (Run flutter format to format lib/model/config_info.dart.)
  • lib/utils/font.dart (Run flutter format to format lib/utils/font.dart.)
  • lib/utils/image.dart (Run flutter format to format lib/utils/image.dart.)
  • lib/utils/text.dart (Run flutter format to format lib/utils/text.dart.)

Maintenance issues and suggestions

Support latest dependencies. (-10 points)

The version constraint in pubspec.yaml does not support the latest published versions for 1 dependency (url_launcher).

The package description is too short. (-20 points)

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

Maintain an example. (-10 points)

Create a short demo in the example/ directory to show how to use this package.

Common filename patterns include main.dart, example.dart, and base_flutter.dart. Packages with multiple examples should provide example/README.md.

For more information see the pub package layout conventions.

Package is pre-v0.1 release. (-10 points)

While nothing is inherently wrong with versions of 0.0.*, it might mean that the author is still experimenting with the general direction of the API.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.1.0 <3.0.0
flutter 0.0.0
url_launcher ^4.0.2 4.2.0+3 5.4.1
Transitive dependencies
collection 1.14.11 1.14.12
meta 1.1.8
sky_engine 0.0.99
typed_data 1.1.6
vector_math 2.0.8
Dev dependencies
flutter_test