base_api_client 0.0.3
base_api_client: ^0.0.3 copied to clipboard

Base API Client to handle API calling and errors easily with loading.

2
likes
100/ 130
pub points
24%
popularity

We analyzed this package on Oct 21, 2021, and awarded it 100 pub points (of a possible 130):

Follow Dart file conventions
20 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
0 / 20

0/10 points: Package has an example

No example found.

See package layout guidelines on how to add an example.

0/10 points: Failed to run dartdoc

  • dartdoc failed with:
exitCode: 255
stdout: [2021-10-20T10:30:21.674724] Starting...
Documenting base_api_client...

stderr: Unhandled exception:
FileSystemException(path=/tmp/pub-dartlang-dartdocERXUAG/pkg/lib/BaseApiClient/ApiController.dart; message=Cannot open file)
#0      _PhysicalFile.readAsStringSync (package:analyzer/file_system/physical_file_system.dart:185:7)
#1      _File.readAsStringSync (package:pub_dartdoc/src/pub_hooks.dart:164:42)
#2      PubPackageBuilder.findFilesToDocumentInPackage (package:dartdoc/src/model/package_builder.dart:277:58)
<asynchronous suspension>
#3      Stream.toList.<anonymous closure> (dart:async/stream.dart)
<asynchronous suspension>


Support multiple platforms
10 / 20

10/20 points: Supports 2 of 3 possible platforms (iOS, Android, Web)

Consider supporting multiple platforms:

Package not compatible with runtime flutter-web on Web

Because:

  • package:base_api_client/base_api_client.dart that imports:
  • dart:io
Pass static analysis
30 / 30

30/30 points: code has no errors, warnings, lints, or formatting issues

Support up-to-date dependencies
20 / 20

10/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
flutterflutter0.0.00.0.0
get^4.3.84.3.84.3.8
http^0.13.30.13.40.13.4
Transitive dependencies
PackageConstraintCompatibleLatest
async-2.8.22.8.2
characters-1.1.01.2.0
charcode-1.3.11.3.1
collection-1.15.01.15.0
http_parser-4.0.04.0.0
meta-1.7.01.7.0
path-1.8.01.8.0
sky_engine-0.0.990.0.99
source_span-1.8.11.8.1
string_scanner-1.1.01.1.0
term_glyph-1.2.01.2.0
typed_data-1.3.01.3.0
vector_math-2.1.02.1.1

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Support sound null safety
20 / 20

20/20 points: Package and dependencies are fully migrated to null safety!

Analysed with Pana 0.21.3, Flutter 2.5.2, Dart 2.14.3.

2
likes
100
pub points
24%
popularity

Base API Client to handle API calling and errors easily with loading.

Repository (GitHub)
View/report issues

License

MIT (LICENSE)

Dependencies

flutter, get, http

More

Packages that depend on base_api_client