bakalari 0.3.3

Dart native js
Flutter Android iOS web

Wrapper for Czech school system Bakaláři. Grants access to data that are not accessible by official app.

0
likes
90 / 110
pub points
8 %
popularity

We analyzed this package on Sep 19, 2020, and awarded it 90 pub points (of a possible 110):

Follow Dart file conventions
20 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
20 / 20

10/10 points: Package has an example

  • Found example at: example/main.dart

10/10 points: 20% or more of the public API has dartdoc comments

  • 136 out of 187 API elements (72.7 %) have documentation comments.
Support multiple platforms
20 / 20

20/20 points: Supports 2 of 2 possible platforms (native, js)

Pass static analysis
20 / 30

20/30 points: code has no errors, warnings, lints, or formatting issues

Found 24 issues. Showing the first 2:

INFO: Unnecessary new keyword.

lib/bakalari.dart:115:17

    ╷
115 │       _school = new School();
    │                 ^^^^^^^^^^^^
    ╵

To reproduce make sure you are using pedantic and run dartanalyzer lib/bakalari.dart

INFO: Unnecessary new keyword.

lib/bakalari.dart:127:18

    ╷
127 │       _student = new Student();
    │                  ^^^^^^^^^^^^^
    ╵

To reproduce make sure you are using pedantic and run dartanalyzer lib/bakalari.dart

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
http^0.12.0+20.12.20.12.2
intl^0.15.80.15.80.16.1
json_annotation^2.4.02.4.03.0.1
pointycastle^1.0.11.0.21.0.2
xml^3.5.03.7.04.5.1
Transitive dependencies
PackageConstraintCompatibleLatest
charcode-1.1.31.1.3
collection-1.14.131.14.13
convert-2.1.12.1.1
http_parser-3.1.43.1.4
meta-1.2.31.2.3
path-1.7.01.7.0
pedantic-1.9.21.9.2
petitparser-3.1.03.1.0
source_span-1.7.01.7.0
string_scanner-1.0.51.0.5
term_glyph-1.1.01.1.0
typed_data-1.2.01.2.0

To reproduce run pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

Found 3 issues. Showing the first 2:

The constraint `^0.15.8` on intl does not support the latest published version `0.16.1`

pubspec.yaml:14:15

   ╷
14 │         intl: ^0.15.8 # Needed for date formatting
   │               ^^^^^^^
   ╵
The constraint `^2.4.0` on json_annotation does not support the latest published version `3.0.1`

pubspec.yaml:16:26

   ╷
16 │         json_annotation: ^2.4.0 # Somehow needed for json (de)serialization
   │                          ^^^^^^
   ╵

10/10 points: Package supports latest stable Dart and Flutter SDKs

0
likes
90
pub points
8%
popularity

Wrapper for Czech school system Bakaláři. Grants access to data that are not accessible by official app.

Repository (GitHub)
View/report issues

Documentation

API reference

Uploader

petr.stastny01@gmail.com

License

GPL 2.0 (LICENSE)

Dependencies

http, intl, json_annotation, pointycastle, xml

More

Packages that depend on bakalari