aws_opsworks_api 2.0.0 copy "aws_opsworks_api: ^2.0.0" to clipboard
aws_opsworks_api: ^2.0.0 copied to clipboard

AWS API client for AWS OpsWorks (generated from SDK API specification).

0
likes
130/ 140
pub points
0%
popularity

We analyzed this package 3 days ago, and awarded it 130 pub points (of a possible 140):

OK
Follow Dart file conventions
30 / 30trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: Apache-2.0.

OK
Provide documentation
20 / 20trigger folding of the section

10/10 points: 20% or more of the public API has dartdoc comments

538 out of 733 API elements (73.4 %) have documentation comments.

Some symbols that are missing documentation: opsworks-2013-02-18, opsworks-2013-02-18.AgentVersion.AgentVersion.fromJson, opsworks-2013-02-18.App.App.fromJson, opsworks-2013-02-18.AppAttributesKeys, opsworks-2013-02-18.AppAttributesKeys.AppAttributesKeys.

10/10 points: Package has an example

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 6 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ Windows
  • ✓ Linux
  • ✓ macOS
  • ✓ Web
partial
Pass static analysis
40 / 50trigger folding of the section

40/50 points: code has no errors, warnings, lints, or formatting issues

INFO: The file name 'opsworks-2013-02-18.dart' isn't a lower_case_with_underscores identifier.

To reproduce make sure you are using the lints_core and run dart analyze lib/opsworks-2013-02-18.dart

OK
Support up-to-date dependencies
20 / 20trigger folding of the section

10/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
shared_aws_api ^2.0.0 2.0.1 2.0.1
Transitive dependencies
Package Constraint Compatible Latest
async - 2.11.0 2.11.0
clock - 1.1.1 1.1.1
collection - 1.18.0 1.18.0
crypto - 3.0.3 3.0.3
http - 0.13.6 1.2.1
http_parser - 4.0.2 4.0.2
intl - 0.18.1 0.19.0
meta - 1.12.0 1.12.0
path - 1.9.0 1.9.0
petitparser - 6.0.2 6.0.2
source_span - 1.10.0 1.10.0
string_scanner - 1.2.0 1.2.0
term_glyph - 1.2.1 1.2.1
typed_data - 1.3.2 1.3.2
uuid - 3.0.7 4.3.3
xml - 6.5.0 6.5.0

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analyzed with Pana 0.22.0, Dart 3.3.0.

Check the analysis log for details.

0
likes
130
pub points
0%
popularity

Publisher

verified publisheraws-dart.agilord.com

AWS API client for AWS OpsWorks (generated from SDK API specification).

Repository (GitHub)
View/report issues

Documentation

API reference

License

Apache-2.0 (LICENSE)

Dependencies

shared_aws_api

More

Packages that depend on aws_opsworks_api