awesome_card 1.1.6 copy "awesome_card: ^1.1.6" to clipboard
awesome_card: ^1.1.6 copied to clipboard

Flutter package to create a Credit Card Widget in your application.

277
likes
135/ 160
pub points
97%
popularity

We analyzed this package 6 days ago, and awarded it 135 pub points (of a possible 160):

failed
Follow Dart file conventions
25 / 30trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

0/5 points: Provide a valid README.md

Links in `README.md` should be secure. 1 link is insecure.

README.md:43:5

   ╷
43 │ <li><a href="http://github.com/iamvivekkaushik/">Vivek Kaushik</a></li>
   │     ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
   ╵

Use https URLs instead.

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: MIT.

partial
Provide documentation
10 / 20trigger folding of the section

0/10 points: 20% or more of the public API has dartdoc comments

4 out of 71 API elements (5.6 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

To highlight public API members missing documentation consider enabling the public_member_api_docs lint.

Some symbols that are missing documentation: awesome_card, card_back_layout, card_back_layout.CardBackLayout, card_back_layout.CardBackLayout.CardBackLayout, card_back_layout.CardBackLayout.color.

10/10 points: Package has an example

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 6 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ Windows
  • ✓ Linux
  • ✓ macOS
  • ✓ Web
partial
Pass static analysis
40 / 50trigger folding of the section

40/50 points: code has no errors, warnings, lints, or formatting issues

Found 5 issues. Showing the first 2:

INFO: The import of 'package:awesome_card/extra/helper.dart' is unnecessary because all of the used elements are also provided by the import of 'package:awesome_card/awesome_card.dart'.

lib/credit_card.dart:4:8

  ╷
4 │ import 'package:awesome_card/extra/helper.dart';
  │        ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
  ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/credit_card.dart

INFO: The import of 'package:flutter/cupertino.dart' is unnecessary because all of the used elements are also provided by the import of 'package:flutter/material.dart'.

lib/credit_card.dart:5:8

  ╷
5 │ import 'package:flutter/cupertino.dart';
  │        ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
  ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/credit_card.dart

OK
Support up-to-date dependencies
40 / 40trigger folding of the section

10/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
flutter flutter 0.0.0 0.0.0
Transitive dependencies
Package Constraint Compatible Latest
characters - 1.3.0 1.3.0
collection - 1.18.0 1.19.0
material_color_utilities - 0.8.0 0.12.0
meta - 1.12.0 1.15.0
sky_engine - 0.0.99 0.0.99
vector_math - 2.1.4 2.1.4

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

20/20 points: Compatible with dependency constraint lower bounds

pub downgrade does not expose any static analysis error.

Analyzed with Pana 0.22.8, Flutter 3.22.2, Dart 3.4.3.

Check the analysis log for details.

277
likes
135
pub points
97%
popularity

Publisher

verified publishervivekkaushik.com

Flutter package to create a Credit Card Widget in your application.

Repository (GitHub)
View/report issues

Documentation

API reference

License

MIT (license)

Dependencies

flutter

More

Packages that depend on awesome_card