automated_testing_framework_plugin_sqflite 1.0.1
automated_testing_framework_plugin_sqflite: ^1.0.1 copied to clipboard

Library to use SQLite Database as a storage mechanism for automated tests and test results.

0
likes
90/ 130
pub points
0%
popularity

We analyzed this package on Oct 22, 2021, and awarded it 90 pub points (of a possible 130):

Follow Dart file conventions
20 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
20 / 20

10/10 points: Package has an example

  • Found example at: example/lib/main.dart

10/10 points: 20% or more of the public API has dartdoc comments

  • 9 out of 10 API elements (90.0 %) have documentation comments.
Support multiple platforms
10 / 20

10/20 points: Supports 2 of 3 possible platforms (iOS, Android, Web)

Found 6 issues. Showing the first 2:

Consider supporting multiple platforms:

Package does not support Flutter platform `Web`.

Because:

  • package:automated_testing_framework_plugin_sqflite/automated_testing_framework_plugin_sqflite.dart that imports:
  • package:automated_testing_framework_plugin_sqflite/src/sqflite_test_store.dart that imports:
  • package:sqflite/sqflite.dart that declares support for platforms: Android, iOS, macOS.
Pass static analysis
30 / 30

30/30 points: code has no errors, warnings, lints, or formatting issues

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
automated_testing_framework^1.2.6+31.3.43.1.1+1
convert^2.1.12.1.13.0.1
flutterflutter0.0.00.0.0
logging^0.11.40.11.41.0.2
meta^1.1.81.7.01.7.0
sqflite^1.3.1+11.3.2+42.0.0+4
Transitive dependencies
PackageConstraintCompatibleLatest
args-1.6.02.3.0
automated_testing_framework_models-1.1.12.0.8
characters-1.1.01.2.0
charcode-1.3.11.3.1
child_builder-1.0.0+22.0.0
collection-1.15.01.15.0
crypto-2.1.53.0.1
device_info-1.0.02.0.2
device_info_platform_interface-1.0.12.0.1
form_validation-1.0.2+12.0.0+1
http-0.12.20.13.4
http_parser-3.1.44.0.0
intl-0.16.10.17.0
json_class-1.0.7+22.0.0+2
json_schema2-1.0.0+12.0.0+3
json_theme-1.5.0+23.0.1
matcher-0.12.110.12.11
nested-1.0.01.0.0
package_info-0.4.3+42.0.2
path-1.8.01.8.0
pedantic-1.11.11.11.1
pigment-1.0.41.0.4
plugin_platform_interface-1.0.32.0.2
pointycastle-2.0.13.3.4
provider-4.3.36.0.1
quiver-2.1.53.0.1+1
rest_client-1.0.6+22.0.1+3
sky_engine-0.0.990.0.99
source_span-1.8.11.8.1
sqflite_common-1.0.3+32.0.1+1
stack_trace-1.10.01.10.0
static_translations-1.0.3+12.0.2+2
string_scanner-1.1.01.1.0
synchronized-2.2.0+23.0.0
term_glyph-1.2.01.2.0
tinycolor-1.0.31.0.3
typed_data-1.3.01.3.0
uri-0.11.41.0.0
uuid-2.2.23.0.5
vector_math-2.1.02.1.1
websafe_platform-1.1.01.1.0

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

Found 4 issues. Showing the first 2:

The constraint `^1.2.6+3` on automated_testing_framework does not support the stable version `2.0.0`.

Try running dart pub upgrade --major-versions automated_testing_framework to update the constraint.

The constraint `^2.1.1` on convert does not support the stable version `3.0.0`.

Try running dart pub upgrade --major-versions convert to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Support sound null safety
0 / 20

0/20 points: Package does not opt in to null safety.

Package language version (indicated by the sdk constraint `>=2.7.0 <3.0.0`) is less than 2.12.

Consider migrating.

Analysed with Pana 0.21.3, Flutter 2.5.2, Dart 2.14.3.

0
likes
90
pub points
0%
popularity

Library to use SQLite Database as a storage mechanism for automated tests and test results.

Repository (GitHub)
View/report issues

Documentation

API reference

License

MIT (LICENSE)

Dependencies

automated_testing_framework, convert, flutter, logging, meta, sqflite

More

Packages that depend on automated_testing_framework_plugin_sqflite