auto_route 8.3.0 copy "auto_route: ^8.3.0" to clipboard
auto_route: ^8.3.0 copied to clipboard

AutoRoute is a declarative routing solution, where everything needed for navigation is automatically generated for you.

2914
likes
160/ 160
pub points
99%
popularity

We analyzed this package 17 hours ago, and awarded it 160 pub points (of a possible 160):

OK
Follow Dart file conventions
30 / 30trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: MIT.

OK
Provide documentation
20 / 20trigger folding of the section

10/10 points: 20% or more of the public API has dartdoc comments

762 out of 765 API elements (99.6 %) have documentation comments.

Some symbols that are missing documentation: annotations, auto_route, auto_route.AutoRouterDelegate.reevaluateListenable.

10/10 points: Package has an example

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 6 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ Windows
  • ✓ Linux
  • ✓ macOS
  • ✓ Web
OK
Pass static analysis
50 / 50trigger folding of the section

50/50 points: code has no errors, warnings, lints, or formatting issues

OK
Support up-to-date dependencies
40 / 40trigger folding of the section

10/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
collection ^1.18.0 1.18.0 1.19.0
flutter flutter 0.0.0 0.0.0
meta ^1.12.0 1.12.0 1.15.0
path ^1.9.0 1.9.0 1.9.0
web ^0.5.1 0.5.1 1.0.0
Transitive dependencies
Package Constraint Compatible Latest
characters - 1.3.0 1.3.0
material_color_utilities - 0.8.0 0.12.0
sky_engine - 0.0.99 0.0.99
vector_math - 2.1.4 2.1.4

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^0.5.1` on web does not support the stable version `1.0.0`, that was published 2 days ago.

When web is 30 days old, this package will no longer be awarded points in this category.

Try running dart pub upgrade --major-versions web to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

20/20 points: Compatible with dependency constraint lower bounds

pub downgrade does not expose any static analysis error.

Analyzed with Pana 0.22.9, Flutter 3.22.2, Dart 3.4.3.

Check the analysis log for details.

2914
likes
160
pub points
99%
popularity

Publisher

verified publishercodeness.ly

AutoRoute is a declarative routing solution, where everything needed for navigation is automatically generated for you.

Repository (GitHub)
View/report issues

Documentation

API reference

License

MIT (license)

Dependencies

collection, flutter, meta, path, web

More

Packages that depend on auto_route