auth0_lib 0.5.2
auth0_lib: ^0.5.2 copied to clipboard

Flutter toolkit for Auth0 API and web pkce flow authentication. Forked: https://github.com/devdennysegura/flutter-auth0

0
likes
70 / 130
pub points
7 %
popularity

We analyzed this package on Jul 23, 2021, and awarded it 70 pub points (of a possible 130):

Follow Dart file conventions
20 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
10 / 20

10/10 points: Package has an example

  • Found example at: example/lib/main.dart

0/10 points: 20% or more of the public API has dartdoc comments

  • 2 out of 77 API elements (2.6 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

Support multiple platforms
10 / 20

10/20 points: Supports 2 of 3 possible platforms (iOS, Android, Web)

Found 6 issues. Showing the first 2:

Consider supporting multiple platforms:

Package does not support Flutter platform Web

Because:

  • package:auth0_lib/auth0_lib.dart that declares support for platforms: Android, iOS
Pass static analysis
20 / 30

20/30 points: code has no errors, warnings, lints, or formatting issues

lib/src/auth/index.dart is not formatted according to dartfmt

To format your files run: dartfmt -w .

lib/src/management/users.dart is not formatted according to dartfmt

To format your files run: dartfmt -w .

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
flutterflutter0.0.00.0.0
http^0.12.0+20.12.20.13.3
meta^1.1.61.3.01.7.0
Transitive dependencies
PackageConstraintCompatibleLatest
characters-1.1.01.1.0
charcode-1.3.11.3.1
collection-1.15.01.15.0
http_parser-3.1.44.0.0
path-1.8.01.8.0
pedantic-1.11.11.11.1
sky_engine-0.0.990.0.99
source_span-1.8.11.8.1
string_scanner-1.1.01.1.0
term_glyph-1.2.01.2.0
typed_data-1.3.01.3.0
vector_math-2.1.02.1.0

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^0.12.0+2` on http does not support the stable version `0.13.0`.

Try running dart pub upgrade --major-versions http to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Support sound null safety
0 / 20

0/20 points: Package does not opt in to null safety.

Package language version (indicated by the sdk constraint `>=2.1.0 <3.0.0`) is less than 2.12.

Consider migrating.

Analysed with Pana 0.19.0, Flutter 2.2.3, Dart 2.13.4.

0
likes
70
pub points
7%
popularity

Publisher

bits.cr

Flutter toolkit for Auth0 API and web pkce flow authentication. Forked: https://github.com/devdennysegura/flutter-auth0

Repository (GitHub)
View/report issues

Documentation

API reference

License

MIT (LICENSE)

Dependencies

flutter, http, meta

More

Packages that depend on auth0_lib