audio_editor 0.0.1
audio_editor: ^0.0.1 copied to clipboard

A new Flutter package project.

2
likes
70/ 130
pub points
0%
popularity

We analyzed this package on Oct 22, 2021, and awarded it 70 pub points (of a possible 130):

Follow Dart file conventions
10 / 20

0/10 points: Provide a valid pubspec.yaml

Repository URL doesn't exist.

At the time of the analysis https://github.com/zeucxb/audio_editor was unreachable.

The package description is too short.

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
10 / 20

10/10 points: Package has an example

  • Found example at: example/lib/main.dart

0/10 points: 20% or more of the public API has dartdoc comments

  • 1 out of 20 API elements (5.0 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

Support multiple platforms
10 / 20

10/20 points: Supports 2 of 3 possible platforms (iOS, Android, Web)

Found 9 issues. Showing the first 2:

Consider supporting multiple platforms:

Package does not support Flutter platform `Web`.

Because:

  • package:audio_editor/audio_editor.dart that imports:
  • package:audio_editor/audio.dart that imports:
  • package:flutter_ffmpeg/flutter_ffmpeg.dart that declares support for platforms: Android, iOS.
Pass static analysis
30 / 30

30/30 points: code has no errors, warnings, lints, or formatting issues

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
flutterflutter0.0.00.0.0
flutter_ffmpeg^0.2.100.2.100.4.2
path_provider^1.6.111.6.282.0.5
Transitive dependencies
PackageConstraintCompatibleLatest
characters-1.1.01.2.0
collection-1.15.01.15.0
ffi-1.1.21.1.2
file-6.1.26.1.2
meta-1.7.01.7.0
path-1.8.01.8.0
path_provider_linux-0.0.1+22.1.0
path_provider_macos-0.0.4+82.0.2
path_provider_platform_interface-1.0.42.0.1
path_provider_windows-0.0.52.0.3
platform-3.0.23.0.2
plugin_platform_interface-1.0.32.0.2
process-4.2.44.2.4
sky_engine-0.0.990.0.99
typed_data-1.3.01.3.0
vector_math-2.1.02.1.1
win32-2.2.102.2.10
xdg_directories-0.1.20.2.0

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^0.2.10` on flutter_ffmpeg does not support the stable version `0.3.0`.

Try running dart pub upgrade --major-versions flutter_ffmpeg to update the constraint.

The constraint `^1.6.11` on path_provider does not support the stable version `2.0.0`.

Try running dart pub upgrade --major-versions path_provider to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Support sound null safety
0 / 20

0/20 points: Package does not opt in to null safety.

Package language version (indicated by the sdk constraint `>=2.7.0 <3.0.0`) is less than 2.12.

Consider migrating.

Analysed with Pana 0.21.3, Flutter 2.5.2, Dart 2.14.3.

2
likes
70
pub points
0%
popularity

A new Flutter package project.

Repository (missing)
View/report issues

Documentation

API reference

License

LGPL-3.0 (LICENSE)

Dependencies

flutter, flutter_ffmpeg, path_provider

More

Packages that depend on audio_editor