at_utils 1.0.1+6
at_utils: ^1.0.1+6 copied to clipboard

This is the Utility library for @protocol projects. It contains utility classes for atsign, atmetadata, configuration and logger.

1
likes
70 / 110
pub points
83 %
popularity

We analyzed this package on Apr 13, 2021, and awarded it 70 pub points (of a possible 110):

Follow Dart file conventions
20 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
10 / 20

10/10 points: Package has an example

  • Found example at: example/main.dart

0/10 points: 20% or more of the public API has dartdoc comments

  • 6 out of 37 API elements (16.2 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

Support multiple platforms
10 / 20

10/20 points: Supports 1 of 2 possible platforms (native, js)

Consider supporting multiple platforms:

Package not compatible with runtime js

Because:

  • package:at_utils/at_utils.dart that imports:
  • package:at_utils/at_logger.dart that imports:
  • package:at_utils/src/logging/atsignlogger.dart that imports:
  • package:at_utils/src/logging/handlers.dart that imports:
  • dart:io
Pass static analysis
20 / 30

20/30 points: code has no errors, warnings, lints, or formatting issues

INFO: This function has a return type of 'bool', but doesn't end with a return statement.

lib/src/atmetadata_utils.dart:57:15

   ╷
57 │   static bool getBoolVerbParams(String arg1) {
   │               ^^^^^^^^^^^^^^^^^
   ╵

To reproduce make sure you are using pedantic and run dartanalyzer lib/src/atmetadata_utils.dart

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
at_commons^1.0.1+61.0.1+61.0.1+6
crypto^2.1.52.1.53.0.1
logging^0.11.40.11.41.0.1
yaml^2.2.02.2.13.1.0
Transitive dependencies
PackageConstraintCompatibleLatest
charcode-1.2.01.2.0
collection-1.15.01.15.0
convert-2.1.13.0.0
path-1.8.01.8.0
source_span-1.8.11.8.1
string_scanner-1.1.01.1.0
term_glyph-1.2.01.2.0
typed_data-1.3.01.3.0

To reproduce run pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

Found 3 issues. Showing the first 2:

The constraint `^2.1.5` on crypto does not support the stable version `3.0.0`.

Try running dart pub upgrade --major-versions crypto to update the constraint.

The constraint `^0.11.4` on logging does not support the stable version `1.0.0`.

Try running dart pub upgrade --major-versions logging to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analysed with Pana 0.15.4, Dart 2.12.2.

1
likes
70
pub points
83%
popularity

Publisher

atsign.org

This is the Utility library for @protocol projects. It contains utility classes for atsign, atmetadata, configuration and logger.

Homepage
Repository (GitHub)
View/report issues

Documentation

API reference

License

BSD (LICENSE)

Dependencies

at_commons, crypto, logging, yaml

More

Packages that depend on at_utils