archive 3.6.0 copy "archive: ^3.6.0" to clipboard
archive: ^3.6.0 copied to clipboard

Provides encoders and decoders for various archive and compression formats such as zip, tar, bzip2, gzip, and zlib.

668
likes
130/ 140
pub points
100%
popularity

We analyzed this package 28 hours ago, and awarded it 130 pub points (of a possible 140):

OK
Follow Dart file conventions
30 / 30trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: MIT.

OK
Provide documentation
20 / 20trigger folding of the section

10/10 points: 20% or more of the public API has dartdoc comments

182 out of 649 API elements (28.0 %) have documentation comments.

Some symbols that are missing documentation: archive, archive.AbstractFileHandle, archive.AbstractFileHandle.AbstractFileHandle, archive.AbstractFileHandle.close, archive.AbstractFileHandle.closeSync.

10/10 points: Package has an example

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 6 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ Windows
  • ✓ Linux
  • ✓ macOS
  • ✓ Web
partial
Pass static analysis
40 / 50trigger folding of the section

40/50 points: code has no errors, warnings, lints, or formatting issues

INFO: The variable name 'CRC32' isn't a lowerCamelCase identifier.

lib/src/util/crc32.dart:5:5

  ╷
5 │ int CRC32(int crc, int b) => _crc32Table[(crc ^ b) & 0xff] ^ (crc >> 8);
  │     ^^^^^
  ╵

To reproduce make sure you are using the lints_core and run dart analyze lib/src/util/crc32.dart

OK
Support up-to-date dependencies
20 / 20trigger folding of the section

10/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
crypto ^3.0.3 3.0.3 3.0.3
path ^1.8.0 1.9.0 1.9.0
Transitive dependencies
Package Constraint Compatible Latest
collection - 1.18.0 1.18.0
typed_data - 1.3.2 1.3.2

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analyzed with Pana 0.22.3, Dart 3.4.0.

Check the analysis log for details.

668
likes
130
pub points
100%
popularity

Publisher

verified publisherloki3d.com

Provides encoders and decoders for various archive and compression formats such as zip, tar, bzip2, gzip, and zlib.

Repository (GitHub)
View/report issues

Topics

#archive #zip #tar #gzip #xz

Documentation

API reference

License

MIT (LICENSE)

Dependencies

crypto, path

More

Packages that depend on archive