arbify 0.0.6

  • Readme
  • Changelog
  • Installing
  • new68

arbify #

pub package Flutter workflow

A package providing support for internationalizing Flutter applications using intl package with Arbify.

Usage #

$ flutter pub run arbify:download --help
Arbify download command-line utility.
-h, --help                Shows this help message.
-i, --[no-]interactive    Whether the command-line utility can ask you interactively.
                          (defaults to on)
-s, --secret=<secret>     Secret to be used for authenticating to the Arbify API.  
                          Overrides the secret from the .secret.arbify file. 

Use flutter pub run arbify:download to run a command-line utility that will guide you through setting up arbify package. This generally comes to two things:

  1. Adding configuration to your pubspec.yaml file

     arbify:
         url: https://arb.company.com
         project_id: 17
         outpur_dir: lib/l10n # default, can be ommited
    
  2. Adding your secret (obtained at https://arb.company.com/account/secrets/create) to .secret.arbify file.

Sample output #

$ flutter pub run arbify:download

Output directory doesn't exist. Creating... done.
en                  Downloading... done.
pl                  Downloading... done.
mk                  Downloading... done.
Generating l10n.dart file... done 
Generating messages dart files... done

[0.0.6] #

  • Fix l10n.dart generator for languages with only country name provided.

[0.0.5] #

  • Always provide countryCode for Locales in l10n.dart. Fixes an exception.

[0.0.4] #

  • Fix error generating description argument instead of desc in l10n.dart.
  • Add delegate field to l10n.dart generator.
  • Add supportedLocales to l10n.dart generator.

[0.0.3] #

  • Fix health suggestions.
  • Fix NoSuchMethodError when running without pubspec config.

[0.0.2] #

  • Fix petitparser version constraint error on some Flutter branches.

[0.0.1] - First release #

This is the first release of arbify package! It still needs tests and testing, but generally should work.

[0.0.0] - Parking package name #

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  arbify: ^0.0.6

2. Install it

You can install packages from the command line:

with Flutter:


$ flutter pub get

Alternatively, your editor might support flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:arbify/arbify_download.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
45
Health:
Code health derived from static analysis. [more]
100
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
80
Overall:
Weighted score of the above. [more]
68
Learn more about scoring.

We analyzed this package on Jul 2, 2020, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.8.4
  • pana: 0.13.13
  • Flutter: 1.17.5

Analysis suggestions

Package not compatible with SDK dart

because of import path [arbify] that is in a package requiring null.

Package not compatible with runtime flutter-web on web

Because of the import of dart:io via the import chain package:arbify/arbify_download.dartpackage:arbify/src/output_file_utils.dartdart:io

Maintenance suggestions

Maintain an example. (-10 points)

Create a short demo in the example/ directory to show how to use this package.

Common filename patterns include main.dart, example.dart, and arbify.dart. Packages with multiple examples should provide example/README.md.

For more information see the pub package layout conventions.

Package is pre-v0.1 release. (-10 points)

While nothing is inherently wrong with versions of 0.0.*, it might mean that the author is still experimenting with the general direction of the API.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.7.0 <3.0.0
args ^1.6.0 1.6.0
dio ^3.0.9 3.0.9
flutter 0.0.0
intl_translation ^0.17.10 0.17.10
meta ^1.1.8 1.1.8
path ^1.6.4 1.7.0
pedantic ^1.0.0 1.9.0 1.9.1
petitparser >=2.4.0 <4.0.0 3.0.4
yaml ^2.2.1 2.2.1
Transitive dependencies
_fe_analyzer_shared 5.0.0
analyzer 0.39.11
async 2.4.1
charcode 1.1.3
collection 1.14.12 1.14.13
convert 2.1.1
crypto 2.1.5
csslib 0.16.1
dart_style 1.3.6
glob 1.2.0
html 0.14.0+3
http_parser 3.1.4
intl 0.16.1
js 0.6.2
node_interop 1.1.1
node_io 1.1.1
package_config 1.9.3
pub_semver 1.4.4
sky_engine 0.0.99
source_span 1.7.0
string_scanner 1.0.5
term_glyph 1.1.0
typed_data 1.1.6 1.2.0
vector_math 2.0.8
watcher 0.9.7+15
Dev dependencies
mockito ^4.1.1
test ^1.14.7