aquedart 5.0.4 icon indicating copy to clipboard operation
aquedart: ^5.0.4 copied to clipboard

SDKDart

A modern HTTP server application framework, ORM and OAuth2 provider with OpenAPI 3.0 integration. Foundation for REST, RPC or GraphQL services.

3
likes
85/ 130
pub points
36%
popularity

We analyzed this package 2 days ago, and awarded it 85 pub points (of a possible 130):

icon indicating section status
Follow Dart file conventions
15 / 20icon to trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

0/5 points: Provide a valid README.md

Links in `README.md` should be secure. 1 link is insecure.

README.md:3:4

  ╷
3 │ <p><a href="http://slackaquedartsignup.herokuapp.com/"><img src="https://slackaquedartsignup.herokuapp.com/badge.svg" alt="Slack" /></a></p>
  │    ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
  ╵

Use https URLs instead.

5/5 points: Provide a valid CHANGELOG.md

icon indicating section status
Provide documentation
20 / 20icon to trigger folding of the section

10/10 points: Package has an example

10/10 points: 20% or more of the public API has dartdoc comments

  • 1039 out of 1366 API elements (76.1 %) have documentation comments.
icon indicating section status
Platform support
0 / 20icon to trigger folding of the section

0/20 points: Supports 0 of 6 possible platforms (iOS, Android, Web, Windows, MacOS, Linux)

These platforms are not supported:

Package not compatible with platform Android

Because:

  • package:aquedart/aquedart.dart that imports:
  • package:aquedart/src/http/http.dart that imports:
  • package:aquedart/src/http/serializable.dart that imports:
  • package:replica/replica.dart that imports:
  • package:replica/src/mirror_coerce.dart that imports:
  • dart:mirrors
Package not compatible with platform iOS

Because:

  • package:aquedart/aquedart.dart that imports:
  • package:aquedart/src/http/http.dart that imports:
  • package:aquedart/src/http/serializable.dart that imports:
  • package:replica/replica.dart that imports:
  • package:replica/src/mirror_coerce.dart that imports:
  • dart:mirrors
Package not compatible with platform Windows

Because:

  • package:aquedart/aquedart.dart that imports:
  • package:aquedart/src/http/http.dart that imports:
  • package:aquedart/src/http/serializable.dart that imports:
  • package:replica/replica.dart that imports:
  • package:replica/src/mirror_coerce.dart that imports:
  • dart:mirrors
Package not compatible with platform Linux

Because:

  • package:aquedart/aquedart.dart that imports:
  • package:aquedart/src/http/http.dart that imports:
  • package:aquedart/src/http/serializable.dart that imports:
  • package:replica/replica.dart that imports:
  • package:replica/src/mirror_coerce.dart that imports:
  • dart:mirrors
Package not compatible with platform macOS

Because:

  • package:aquedart/aquedart.dart that imports:
  • package:aquedart/src/http/http.dart that imports:
  • package:aquedart/src/http/serializable.dart that imports:
  • package:replica/replica.dart that imports:
  • package:replica/src/mirror_coerce.dart that imports:
  • dart:mirrors
Package not compatible with platform Web

Because:

  • package:aquedart/aquedart.dart that imports:
  • package:aquedart/src/http/http.dart that imports:
  • package:aquedart/src/http/serializable.dart that imports:
  • package:replica/replica.dart that imports:
  • package:replica/src/mirror_coerce.dart that imports:
  • dart:mirrors
icon indicating section status
Pass static analysis
20 / 30icon to trigger folding of the section

20/30 points: code has no errors, warnings, lints, or formatting issues

Found 41 issues. Showing the first 2:

INFO: The import of 'options.dart' is unnecessary because all of the used elements are also provided by the import of 'application.dart'.

lib/src/application/application_server.dart:11:8

   ╷
11 │ import 'options.dart';
   │        ^^^^^^^^^^^^^^
   ╵

To reproduce make sure you are using the lints_core and run dart analyze lib/src/application/application_server.dart

INFO: The import of 'package:aquedart/src/application/service_registry.dart' is unnecessary because all of the used elements are also provided by the import of 'application.dart'.

lib/src/application/channel.dart:4:8

  ╷
4 │ import 'package:aquedart/src/application/service_registry.dart';
  │        ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
  ╵

To reproduce make sure you are using the lints_core and run dart analyze lib/src/application/channel.dart

icon indicating section status
Support up-to-date dependencies
10 / 20icon to trigger folding of the section

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
analyzer^1.3.01.7.24.6.0
args^2.0.02.3.12.3.1
collection^1.15.01.16.01.16.0
conduit_open_api^3.0.113.1.13.1.1
crypto^3.0.03.0.23.0.2
hasher^3.0.0-b13.0.0-b13.0.0-b1
logging^1.0.11.0.21.0.2
loner^3.0.0-b23.0.13.0.1
meta^1.3.01.8.01.8.0
path^1.8.01.8.21.8.2
postgres^2.3.22.4.62.4.6
pub_cache^0.3.00.3.10.3.1
pub_semver^2.0.02.1.12.1.1
replica^2.0.0-b52.0.22.0.2
safe_yaml^4.0.0-b44.0.0-b44.0.0-b4
yaml^3.1.03.1.13.1.1
Transitive dependencies
PackageConstraintCompatibleLatest
_fe_analyzer_shared-22.0.046.0.0
async-2.9.02.9.0
buffer-1.1.11.1.1
checked_yaml-2.0.12.0.1
cli_util-0.3.50.3.5
conduit_codable-3.1.13.1.1
convert-3.0.23.0.2
file-6.1.26.1.2
glob-2.1.02.1.0
json_annotation-4.6.04.6.0
package_config-2.1.02.1.0
pedantic-1.11.11.11.1
pubspec_parse-1.2.01.2.0
sasl_scram-0.1.10.1.1
saslprep-1.0.21.0.2
source_span-1.9.11.9.1
string_scanner-1.1.11.1.1
term_glyph-1.2.11.2.1
typed_data-1.3.11.3.1
unorm_dart-0.2.00.2.0
watcher-1.0.11.0.1

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^1.3.0` on analyzer does not support the stable version `2.0.0`.

Try running dart pub upgrade --major-versions analyzer to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

icon indicating section status
Support sound null safety
20 / 20icon to trigger folding of the section

20/20 points: Package and dependencies are fully migrated to null safety!

Analysed with Pana 0.21.15, Dart 2.17.6.

3
likes
85
pub points
36%
popularity

Publisher

unverified uploader

A modern HTTP server application framework, ORM and OAuth2 provider with OpenAPI 3.0 integration. Foundation for REST, RPC or GraphQL services.

Homepage
Repository (GitHub)

Documentation

API reference

License

Icon for licenses.BSD-2-Clause (LICENSE)

Dependencies

analyzer, args, collection, conduit_open_api, crypto, hasher, logging, loner, meta, path, postgres, pub_cache, pub_semver, replica, safe_yaml, yaml

More

Packages that depend on aquedart