app_prompter 0.0.2
app_prompter: ^0.0.2 copied to clipboard

Prompt users to a custom action on your app if custom conditions like install time and number of launches are met

2
likes
80/ 130
pub points
0%
popularity

We analyzed this package on Sep 16, 2021, and awarded it 80 pub points (of a possible 130):

Follow Dart file conventions
20 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
20 / 20

10/10 points: Package has an example

  • Found example at: example/lib/main.dart

10/10 points: 20% or more of the public API has dartdoc comments

  • 155 out of 162 API elements (95.7 %) have documentation comments.
Support multiple platforms
10 / 20

10/20 points: Supports 2 of 3 possible platforms (iOS, Android, Web)

Found 9 issues. Showing the first 2:

Consider supporting multiple platforms:

Package does not support Flutter platform `Web`.

Because:

  • package:app_prompter/app_prompter.dart that declares support for platforms: Android, iOS.
Pass static analysis
20 / 30

20/30 points: code has no errors, warnings, lints, or formatting issues

lib/src/core.dart doesn't match the Dart formatter.

To format your files run: flutter format .

lib/src/dialogs.dart doesn't match the Dart formatter.

To format your files run: flutter format .

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
flutterflutter0.0.00.0.0
pedantic>=1.8.0 <2.0.01.11.11.11.1
shared_preferences>=0.5.7 <2.0.00.5.12+42.0.7
Transitive dependencies
PackageConstraintCompatibleLatest
characters-1.1.01.2.0
collection-1.15.01.15.0
ffi-1.1.21.1.2
file-6.1.26.1.2
flutter_web_plugins-0.0.00.0.0
js-0.6.30.6.3
meta-1.3.01.7.0
path-1.8.01.8.0
path_provider_linux-0.0.1+22.1.0
path_provider_platform_interface-1.0.42.0.1
path_provider_windows-0.0.52.0.3
platform-3.0.23.0.2
plugin_platform_interface-1.0.32.0.1
process-4.2.34.2.3
shared_preferences_linux-0.0.2+42.0.2
shared_preferences_macos-0.0.1+112.0.2
shared_preferences_platform_interface-1.0.42.0.0
shared_preferences_web-0.1.2+72.0.2
shared_preferences_windows-0.0.2+32.0.2
sky_engine-0.0.990.0.99
typed_data-1.3.01.3.0
vector_math-2.1.02.1.0
win32-2.2.92.2.9
xdg_directories-0.1.20.2.0

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `>=0.5.7 <2.0.0` on shared_preferences does not support the stable version `2.0.0`.

Try running dart pub upgrade --major-versions shared_preferences to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Support sound null safety
0 / 20

0/20 points: Package does not opt in to null safety.

Package language version (indicated by the sdk constraint `>=2.7.0 <3.0.0`) is less than 2.12.

Consider migrating.

Analysed with Pana 0.20.0, Flutter 2.2.3, Dart 2.13.4.

2
likes
80
pub points
0%
popularity

Prompt users to a custom action on your app if custom conditions like install time and number of launches are met

Repository (GitHub)
View/report issues

Documentation

API reference

License

Apache 2.0 (LICENSE)

Dependencies

flutter, pedantic, shared_preferences

More

Packages that depend on app_prompter