app_links 3.5.0 copy "app_links: ^3.5.0" to clipboard
app_links: ^3.5.0 copied to clipboard

Android App Links, Deep Links, iOs Universal Links and Custom URL schemes handler for Flutter (desktop included).

462
likes
140/ 140
pub points
99%
popularity

We analyzed this package 6 days ago, and awarded it 140 pub points (of a possible 140):

OK
Follow Dart file conventions
30 / 30trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: Apache-2.0.

OK
Provide documentation
20 / 20trigger folding of the section

10/10 points: 20% or more of the public API has dartdoc comments

16 out of 22 API elements (72.7 %) have documentation comments.

Some symbols that are missing documentation: app_links, app_links.AppLinks, app_links.AppLinks.AppLinks, app_links.AppLinksPluginLinux, app_links.AppLinksPluginLinux.AppLinksPluginLinux.

10/10 points: Package has an example

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 6 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ Windows
  • ✓ Linux
  • ✓ macOS
  • ✓ Web

These issues are present but do not affect the score, because they may not originate in your package:

Package does not support platform `Android`.

Because:

  • package:app_links/app_links.dart that imports:
  • package:app_links/src/app_links_linux.dart that imports:
  • package:gtk/gtk.dart that declares support for platforms: Linux.
Package does not support platform `iOS`.

Because:

  • package:app_links/app_links.dart that imports:
  • package:app_links/src/app_links_linux.dart that imports:
  • package:gtk/gtk.dart that declares support for platforms: Linux.
Package does not support platform `Windows`.

Because:

  • package:app_links/app_links.dart that imports:
  • package:app_links/src/app_links_linux.dart that imports:
  • package:gtk/gtk.dart that declares support for platforms: Linux.
Package does not support platform `macOS`.

Because:

  • package:app_links/app_links.dart that imports:
  • package:app_links/src/app_links_linux.dart that imports:
  • package:gtk/gtk.dart that declares support for platforms: Linux.
Package does not support platform `Web`.

Because:

  • package:app_links/app_links.dart that imports:
  • package:app_links/src/app_links_linux.dart that imports:
  • package:gtk/gtk.dart that declares support for platforms: Linux.
OK
Pass static analysis
50 / 50trigger folding of the section

50/50 points: code has no errors, warnings, lints, or formatting issues

OK
Support up-to-date dependencies
20 / 20trigger folding of the section

10/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
flutter flutter 0.0.0 0.0.0
flutter_web_plugins flutter 0.0.0 0.0.0
gtk ^2.1.0 2.1.0 2.1.0
plugin_platform_interface ^2.0.0 2.1.8 2.1.8
Transitive dependencies
Package Constraint Compatible Latest
characters - 1.3.0 1.3.0
collection - 1.18.0 1.18.0
ffi - 2.1.2 2.1.2
material_color_utilities - 0.8.0 0.8.0
meta - 1.11.0 1.12.0
sky_engine - 0.0.99 0.0.99
vector_math - 2.1.4 2.1.4

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analyzed with Pana 0.22.2, Flutter 3.19.1, Dart 3.3.0.

Check the analysis log for details.

462
likes
140
pub points
99%
popularity

Publisher

verified publisheropenapi4j.org

Android App Links, Deep Links, iOs Universal Links and Custom URL schemes handler for Flutter (desktop included).

Repository (GitHub)
View/report issues

Documentation

API reference

License

Apache-2.0 (LICENSE)

Dependencies

flutter, flutter_web_plugins, gtk, plugin_platform_interface

More

Packages that depend on app_links