apn_crashlytics 1.0.2
apn_crashlytics: ^1.0.2 copied to clipboard

A new Appnormal flutter package for crash monitoring that wraps Sentry and Firebase Crashlytics.

0
likes
60/ 130
pub points
0%
popularity

We analyzed this package on Oct 13, 2021, and awarded it 60 pub points (of a possible 130):

Follow Dart file conventions
20 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
0 / 20

0/10 points: Package has an example

No example found.

See package layout guidelines on how to add an example.

0/10 points: 20% or more of the public API has dartdoc comments

  • 0 out of 25 API elements (0.0 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

Support multiple platforms
10 / 20

10/20 points: Supports 2 of 3 possible platforms (iOS, Android, Web)

Found 6 issues. Showing the first 2:

Consider supporting multiple platforms:

Package does not support Flutter platform `Web`.

Because:

  • package:apn_crashlytics/apn_crashlytics.dart that imports:
  • package:package_info/package_info.dart that declares support for platforms: Android, iOS, macOS.
Pass static analysis
20 / 30

20/30 points: code has no errors, warnings, lints, or formatting issues

lib/apn_crashlytics.dart doesn't match the Dart formatter.

To format your files run: flutter format .

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
connectivity>=0.4.0 <2.0.01.0.03.0.6
device_info>=0.4.0 <2.0.01.0.02.0.2
firebase_crashlytics^0.4.0+10.4.0+12.2.3
flutterflutter0.0.00.0.0
package_info>=0.4.0 <2.0.00.4.3+42.0.2
sentry^3.0.13.0.16.0.1
Transitive dependencies
PackageConstraintCompatibleLatest
async-2.8.22.8.2
characters-1.1.01.2.0
charcode-1.3.11.3.1
collection-1.15.01.15.0
connectivity_for_web-0.3.1+40.4.0+1
connectivity_macos-0.1.0+70.2.1+2
connectivity_platform_interface-1.0.62.0.1
device_info_platform_interface-1.0.12.0.1
firebase_core-0.7.01.7.0
firebase_core_platform_interface-3.0.14.0.1
firebase_core_web-0.2.1+31.1.0
firebase_crashlytics_platform_interface-1.1.63.1.3
flutter_web_plugins-0.0.00.0.0
http-0.13.40.13.4
http_parser-4.0.04.0.0
js-0.6.30.6.3
matcher-0.12.110.12.11
meta-1.7.01.7.0
path-1.8.01.8.0
pedantic-1.11.11.11.1
plugin_platform_interface-1.0.32.0.2
quiver-2.1.53.0.1
sky_engine-0.0.990.0.99
source_span-1.8.11.8.1
stack_trace-1.10.01.10.0
string_scanner-1.1.01.1.0
term_glyph-1.2.01.2.0
typed_data-1.3.01.3.0
usage-3.4.24.0.2
vector_math-2.1.02.1.1

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

Found 5 issues. Showing the first 2:

The constraint `>=0.4.0 <2.0.0` on connectivity does not support the stable version `2.0.0`.

Try running dart pub upgrade --major-versions connectivity to update the constraint.

The constraint `>=0.4.0 <2.0.0` on device_info does not support the stable version `2.0.0`.

Try running dart pub upgrade --major-versions device_info to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Support sound null safety
0 / 20

0/20 points: Package does not opt in to null safety.

Package language version (indicated by the sdk constraint `>=2.10.2-0 <3.0.0`) is less than 2.12.

Consider migrating.

Analysed with Pana 0.21.3, Flutter 2.5.2, Dart 2.14.3.

0
likes
60
pub points
0%
popularity

Publisher

appnormal.com

A new Appnormal flutter package for crash monitoring that wraps Sentry and Firebase Crashlytics.

Repository (GitHub)
View/report issues

Documentation

API reference

License

MIT (LICENSE)

Dependencies

connectivity, device_info, firebase_crashlytics, flutter, package_info, sentry

More

Packages that depend on apn_crashlytics