aplayer 0.0.2 icon indicating copy to clipboard operation
aplayer: ^0.0.2 copied to clipboard

Platformweb

A packge for simle play link to audio files for flutter web

0
likes
90/ 140
pub points
0%
popularity

We analyzed this package 3 days ago, and awarded it 90 pub points (of a possible 140):

icon indicating section status
Follow Dart file conventions
20 / 30icon to trigger folding of the section

0/10 points: Provide a valid pubspec.yaml

The package description is too short.

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: Apache-2.0.

icon indicating section status
Provide documentation
10 / 20icon to trigger folding of the section

10/10 points: Package has an example

0/10 points: 20% or more of the public API has dartdoc comments

  • 1 out of 36 API elements (2.8 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

icon indicating section status
Platform support
20 / 20icon to trigger folding of the section

20/20 points: Supports 1 of 6 possible platforms (iOS, Android, Web, Windows, MacOS, Linux)

  • ✓ Web

These platforms are not supported:

Package not compatible with platform Android

Because:

  • package:aplayer/aplayer.dart that imports:
  • package:aplayer/widget_progress.dart that imports:
  • package:aplayer/player.dart that imports:
  • dart:html

Package not compatible with platform iOS

Because:

  • package:aplayer/aplayer.dart that imports:
  • package:aplayer/widget_progress.dart that imports:
  • package:aplayer/player.dart that imports:
  • dart:html

Package not compatible with platform Windows

Because:

  • package:aplayer/aplayer.dart that imports:
  • package:aplayer/widget_progress.dart that imports:
  • package:aplayer/player.dart that imports:
  • dart:html

Package not compatible with platform Linux

Because:

  • package:aplayer/aplayer.dart that imports:
  • package:aplayer/widget_progress.dart that imports:
  • package:aplayer/player.dart that imports:
  • dart:html

Package not compatible with platform macOS

Because:

  • package:aplayer/aplayer.dart that imports:
  • package:aplayer/widget_progress.dart that imports:
  • package:aplayer/player.dart that imports:
  • dart:html
icon indicating section status
Pass static analysis
20 / 30icon to trigger folding of the section

20/30 points: code has no errors, warnings, lints, or formatting issues

Found 9 issues. Showing the first 2:

INFO: Avoid using web-only libraries outside Flutter web plugin packages.

lib/player.dart:2:1

  ╷
2 │ import 'dart:html';
  │ ^^^^^^^^^^^^^^^^^^^
  ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/player.dart

INFO: The value of the field '_errorSub' isn't used.

lib/player.dart:42:22

   ╷
42 │   StreamSubscription _errorSub;
   │                      ^^^^^^^^^
   ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/player.dart

icon indicating section status
Support up-to-date dependencies
20 / 20icon to trigger folding of the section

10/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
flutterflutter0.0.00.0.0
Transitive dependencies
PackageConstraintCompatibleLatest
characters-1.2.11.2.1
collection-1.16.01.17.0
material_color_utilities-0.1.50.2.0
meta-1.8.01.8.0
sky_engine-0.0.990.0.99
vector_math-2.1.22.1.4

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

icon indicating section status
Support sound null safety
0 / 20icon to trigger folding of the section

0/20 points: Package does not opt in to null safety.

Package language version (indicated by the sdk constraint >=2.1.0 <3.0.0) is less than 2.12.

Consider migrating.

Analysed with Pana 0.21.21, Flutter 3.3.9, Dart 2.18.5.

0
likes
90
pub points
0%
popularity

Publisher

verified publisher iconouril.info

A packge for simle play link to audio files for flutter web

Repository (GitHub)

Documentation

API reference

License

Icon for licenses.Apache-2.0 (LICENSE)

Dependencies

flutter

More

Packages that depend on aplayer