aplayer 0.0.2

  • Readme
  • Changelog
  • Example
  • Installing
  • 55

aplayer #

A packge for simle play link to audio files for flutter web

[0.0.1] - TODO: Add release date. #

[0.0.2] - TODO: fixed problem with plugin regiser #

  • TODO: Describe initial release.

example/lib/main.dart

import 'dart:html';

import 'package:flutter/material.dart';
import 'package:aplayer/player.dart';
import 'package:aplayer/widget_progress.dart';

void main() => runApp(MyApp());

class MyApp extends StatelessWidget {
  // This widget is the root of your application.
  @override
  Widget build(BuildContext context) {
    return MaterialApp(
      title: 'Flutter Demo',
      theme: ThemeData(
        primarySwatch: Colors.blue,
      ),
      home: MyHomePage(title: 'Flutter Demo Home Page'),
    );
  }
}

class MyHomePage extends StatefulWidget {
  MyHomePage({Key key, this.title}) : super(key: key);

  final String title;

  @override
  _MyHomePageState createState() => _MyHomePageState();
}

class _MyHomePageState extends State<MyHomePage> {
  final audio = APlayer("test.mp3");

  @override
  Widget build(BuildContext context) {
    return Scaffold(
      appBar: AppBar(
        title: Text(widget.title),
      ),
      body: Center(
        child: Column(
          mainAxisAlignment: MainAxisAlignment.center,
          children: <Widget>[
            Wrap(
              children: <Widget>[
                RaisedButton(
                    onPressed: () => audio.stop(), child: Text("stop")),
              ],
            ),
            LinearAudioBar(
              player: audio,
            ),
          ],
        ),
      ),
      floatingActionButton: FloatingActionButton(
        onPressed: () => audio.playPause(),
        child: Icon(Icons.play_arrow),
      ), 
    );
  }
}

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  aplayer: ^0.0.2

2. Install it

You can install packages from the command line:

with Flutter:


$ flutter pub get

Alternatively, your editor might support flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:aplayer/aplayer.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
16
Health:
Code health derived from static analysis. [more]
98
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
89
Overall:
Weighted score of the above. [more]
55
Learn more about scoring.

We analyzed this package on Jul 9, 2020, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.8.4
  • pana: 0.13.14
  • Flutter: 1.17.5

Analysis suggestions

Package not compatible with SDK dart

Because:

  • aplayer that is a package requiring null.

Package not compatible with runtime flutter-native on android

Because:

  • package:aplayer/aplayer.dart that imports:
  • package:aplayer/widget_progress.dart that imports:
  • package:aplayer/player.dart that imports:
  • dart:html

Package not compatible with runtime flutter-native on ios

Because:

  • package:aplayer/aplayer.dart that imports:
  • package:aplayer/widget_progress.dart that imports:
  • package:aplayer/player.dart that imports:
  • dart:html

Package not compatible with runtime flutter-native on linux

Because:

  • package:aplayer/aplayer.dart that imports:
  • package:aplayer/widget_progress.dart that imports:
  • package:aplayer/player.dart that imports:
  • dart:html

Package not compatible with runtime flutter-native on macos

Because:

  • package:aplayer/aplayer.dart that imports:
  • package:aplayer/widget_progress.dart that imports:
  • package:aplayer/player.dart that imports:
  • dart:html

Package not compatible with runtime flutter-native on windows

Because:

  • package:aplayer/aplayer.dart that imports:
  • package:aplayer/widget_progress.dart that imports:
  • package:aplayer/player.dart that imports:
  • dart:html

Health suggestions

Fix lib/widget_progress.dart. (-1.49 points)

Analysis of lib/widget_progress.dart reported 3 hints:

line 7 col 7: This class (or a class that this class inherits from) is marked as '@immutable', but one or more of its instance fields aren't final: LinearAudioBar._progressValue, LinearAudioBar._sub, LinearAudioBar._keyTap

line 9 col 22: The value of the field '_sub' isn't used.

line 9 col 22: Cancel instances of dart.async.StreamSubscription.

Fix lib/player.dart. (-1 points)

Analysis of lib/player.dart reported 2 hints:

line 42 col 22: The value of the field '_errorSub' isn't used.

line 42 col 22: Cancel instances of dart.async.StreamSubscription.

Format lib/exceptions.dart.

Run flutter format to format lib/exceptions.dart.

Format lib/utils.dart.

Run flutter format to format lib/utils.dart.

Maintenance suggestions

Package is pre-v0.1 release. (-10 points)

While nothing is inherently wrong with versions of 0.0.*, it might mean that the author is still experimenting with the general direction of the API.

The package description is too short. (-1 points)

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.1.0 <3.0.0
flutter 0.0.0
Transitive dependencies
collection 1.14.12 1.14.13
meta 1.1.8 1.2.1
sky_engine 0.0.99
typed_data 1.1.6 1.2.0
vector_math 2.0.8 2.1.0-nullsafety
Dev dependencies
flutter_test