apklis_dio_web_api 0.1.0+3 copy "apklis_dio_web_api: ^0.1.0+3" to clipboard
apklis_dio_web_api: ^0.1.0+3 copied to clipboard

Implementación concreta del paquete apklis_web_api para interactuar con la API de Apklis utilizando el paquete dio.

2
likes
110/ 140
pub points
0%
popularity

We analyzed this package 6 days ago, and awarded it 110 pub points (of a possible 140):

OK
Follow Dart file conventions
30 / 30trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: MIT.

failed
Provide documentation
0 / 20trigger folding of the section

0/10 points: 20% or more of the public API has dartdoc comments

0 out of 5 API elements (0.0 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

Some symbols that are missing documentation: apklis_dio_web_api, apklis_dio_web_api.ApklisDioWebApi, apklis_dio_web_api.ApklisDioWebApi.ApklisDioWebApi, apklis_dio_web_api.ApklisDioWebApi.dioClient, apklis_dio_web_api.ApklisDioWebApi.get.

0/10 points: Package has an example

No example found.

See package layout guidelines on how to add an example.

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 6 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ Windows
  • ✓ Linux
  • ✓ macOS
  • ✓ Web
OK
Pass static analysis
50 / 50trigger folding of the section

50/50 points: code has no errors, warnings, lints, or formatting issues

failed
Support up-to-date dependencies
10 / 20trigger folding of the section

0/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
apklis_web_api ^0.3.0 0.3.0+1 0.3.0+1
dio ^4.0.0 4.0.6 5.4.1
Transitive dependencies
Package Constraint Compatible Latest
collection - 1.18.0 1.18.0
freezed_annotation - 0.14.3 2.4.1
http_parser - 4.0.2 4.0.2
json_annotation - 4.8.1 4.8.1
meta - 1.12.0 1.12.0
path - 1.9.0 1.9.0
source_span - 1.10.0 1.10.0
string_scanner - 1.2.0 1.2.0
term_glyph - 1.2.1 1.2.1
typed_data - 1.3.2 1.3.2

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^4.0.0` on dio does not support the stable version `5.0.0`.

Try running dart pub upgrade --major-versions dio to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analyzed with Pana 0.22.2, Dart 3.3.0.

Check the analysis log for details.

2
likes
110
pub points
0%
popularity

Publisher

unverified uploader

Implementación concreta del paquete apklis_web_api para interactuar con la API de Apklis utilizando el paquete dio.

Repository (GitHub)
View/report issues
Contributing

Documentation

API reference

License

MIT (LICENSE)

Dependencies

apklis_web_api, dio

More

Packages that depend on apklis_dio_web_api