api_tools 0.0.4
api_tools: ^0.0.4 copied to clipboard

Flutter Android iOS Linux macOS web Windows

API tools

0
likes
70 / 110
pub points
40 %
popularity

We analyzed this package on Mar 3, 2021, and awarded it 70 pub points (of a possible 110):

Follow Dart file conventions
10 / 20

0/10 points: Provide a valid pubspec.yaml

The package description is too short.

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
0 / 20

0/10 points: Package has an example

No example found.

See package layout guidelines on how to add an example.

0/10 points: 20% or more of the public API has dartdoc comments

  • 7 out of 99 API elements (7.1 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

Support multiple platforms
20 / 20

20/20 points: Supports 3 of 3 possible platforms (iOS, Android, Web)

Pass static analysis
20 / 30

20/30 points: code has no errors, warnings, lints, or formatting issues

Found 3 issues. Showing the first 2:

INFO: Don't import implementation files from another package.

lib/src/http/http_api_client.dart:5:8

  ╷
5 │ import 'package:http/src/utils.dart';
  │        ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
  ╵

To reproduce make sure you are using pedantic and run flutter analyze lib/src/http/http_api_client.dart

INFO: This function has a return type of 'FutureOr

lib/src/http/http_api_client.dart:16:23

   ╷
16 │   Future<APIResponse> request(Endpoint endpoint) async {
   │                       ^^^^^^^
   ╵

To reproduce make sure you are using pedantic and run flutter analyze lib/src/http/http_api_client.dart

Support up-to-date dependencies
20 / 20

10/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
equatable^1.2.51.2.62.0.0
flutterflutter0.0.00.0.0
http^0.12.20.12.20.13.0
http_parser^3.1.43.1.44.0.0
meta^1.1.81.3.01.3.0
path^1.7.01.8.01.8.0
Transitive dependencies
PackageConstraintCompatibleLatest
characters-1.1.01.1.0
charcode-1.2.01.2.0
collection-1.15.01.15.0
pedantic-1.11.01.11.0
sky_engine-0.0.990.0.99
source_span-1.8.11.8.1
string_scanner-1.1.01.1.0
term_glyph-1.2.01.2.0
typed_data-1.3.01.3.0
vector_math-2.1.02.1.0

To reproduce run pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

Found 3 issues. Showing the first 2:

The constraint `^1.2.5` on equatable does not support the stable version `2.0.0`, that was published 1 days ago.

When equatable is 30 days old, this package will no longer be awarded points in this category.

Try running dart pub upgrade --major-versions equatable to update the constraint.

The constraint `^0.12.2` on http does not support the stable version `0.13.0`, that was published 25 days ago.

When http is 30 days old, this package will no longer be awarded points in this category.

Try running dart pub upgrade --major-versions http to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analysed with Pana 0.15.2, Flutter 1.26.0-17.8.pre, Dart 2.12.0 (build 2.12.0-259.16.beta).