api_request 1.0.0-pre-1
api_request: ^1.0.0-pre-1 copied to clipboard

api request for handle call api. every request is an action has execute method.

4
likes
120/ 120
pub points
39%
popularity

We analyzed this package 7 days ago, and awarded it 120 pub points (of a possible 120):

Follow Dart file conventions
20 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
10 / 10

10/10 points: Package has an example

  • Found example at: example/lib/main.dart
Support multiple platforms
20 / 20

20/20 points: Supports 3 of 3 possible platforms (iOS, Android, Web)

Pass static analysis
30 / 30

30/30 points: code has no errors, warnings, lints, or formatting issues

Support up-to-date dependencies
20 / 20

10/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
dio^4.0.04.0.44.0.4
flutterflutter0.0.00.0.0
Transitive dependencies
PackageConstraintCompatibleLatest
characters-1.1.01.2.0
charcode-1.3.11.3.1
collection-1.15.01.15.0
http_parser-4.0.04.0.0
meta-1.7.01.7.0
path-1.8.01.8.0
sky_engine-0.0.990.0.99
source_span-1.8.11.8.1
string_scanner-1.1.01.1.0
term_glyph-1.2.01.2.0
typed_data-1.3.01.3.0
vector_math-2.1.02.1.1

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Support sound null safety
20 / 20

20/20 points: Package and dependencies are fully migrated to null safety!

Analysed with Pana 0.21.4, Flutter 2.5.3, Dart 2.14.4.

4
likes
120
pub points
39%
popularity

Publisher

m-it.dev

api request for handle call api. every request is an action has execute method.

Repository (GitHub)
View/report issues

License

MIT (LICENSE)

Dependencies

dio, flutter

More

Packages that depend on api_request