apex_flutter_sdk 1.1.0
apex_flutter_sdk: ^1.1.0 copied to clipboard

ApexTeam flutter software development kit for ApexTeam co. Open and free for everyone to use <3

8
likes
80/ 130
pub points
38%
popularity

We analyzed this package on Oct 3, 2021, and awarded it 80 pub points (of a possible 130):

Follow Dart file conventions
10 / 20

0/10 points: Provide a valid pubspec.yaml

Homepage URL doesn't exist.

At the time of the analysis https://packs.apexteam.net was unreachable.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
20 / 20

10/10 points: Package has an example

  • Found example at: example/lib/main.dart

10/10 points: 20% or more of the public API has dartdoc comments

  • 66 out of 257 API elements (25.7 %) have documentation comments.
Support multiple platforms
20 / 20

20/20 points: Supports 3 of 3 possible platforms (iOS, Android, Web)

Pass static analysis
20 / 30

20/30 points: code has no errors, warnings, lints, or formatting issues

lib/components/basic/circular_check_box.dart doesn't match the Dart formatter.

To format your files run: flutter format .

lib/components/basic/expandable_chip.dart doesn't match the Dart formatter.

To format your files run: flutter format .

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
flutterflutter0.0.00.0.0
shamsi_date^0.8.10.8.10.15.0
Transitive dependencies
PackageConstraintCompatibleLatest
characters-1.1.01.2.0
collection-1.15.01.15.0
meta-1.7.01.7.0
sky_engine-0.0.990.0.99
typed_data-1.3.01.3.0
vector_math-2.1.02.1.1

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^0.8.1` on shamsi_date does not support the stable version `0.9.0`.

Try running dart pub upgrade --major-versions shamsi_date to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Support sound null safety
0 / 20

0/20 points: Package does not opt in to null safety.

Package language version (indicated by the sdk constraint `>=2.7.0 <3.0.0`) is less than 2.12.

Consider migrating.

Analysed with Pana 0.21.2, Flutter 2.5.1, Dart 2.14.2.

8
likes
80
pub points
38%
popularity

Publisher

packs.apexteam.net

ApexTeam flutter software development kit for ApexTeam co. Open and free for everyone to use <3

Homepage (missing)

Documentation

API reference

License

BSD-3-Clause (LICENSE)

Dependencies

flutter, shamsi_date

More

Packages that depend on apex_flutter_sdk