antlr4 4.11.1 icon indicating copy to clipboard operation
antlr4: ^4.11.1 copied to clipboard

New Dart runtime for ANTLR4.

23
likes
95/ 140
pub points
79%
popularity

We analyzed this package 3 days ago, and awarded it 95 pub points (of a possible 140):

icon indicating section status
Follow Dart file conventions
5 / 30icon to trigger folding of the section

0/10 points: Provide a valid pubspec.yaml

The package description is too short.

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

5/5 points: Provide a valid README.md

0/5 points: Provide a valid CHANGELOG.md

No `CHANGELOG.md` found.

Changelog entries help developers follow the progress of your package. See the example generated by stagehand.

0/10 points: Use an OSI-approved license

No license was recognized.

Consider using an OSI-approved license in the LICENSE file to make it more accessible to the community.

icon indicating section status
Provide documentation
10 / 20icon to trigger folding of the section

0/10 points: Package has an example

No example found.

See package layout guidelines on how to add an example.

10/10 points: 20% or more of the public API has dartdoc comments

  • 727 out of 1445 API elements (50.3 %) have documentation comments.
icon indicating section status
Platform support
20 / 20icon to trigger folding of the section

20/20 points: Supports 6 of 6 possible platforms (iOS, Android, Web, Windows, MacOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ Windows
  • ✓ Linux
  • ✓ MacOS
  • ✓ Web
icon indicating section status
Pass static analysis
20 / 30icon to trigger folding of the section

20/30 points: code has no errors, warnings, lints, or formatting issues

Found 82 issues. Showing the first 2:

INFO: The variable name 'TEST_platformStdoutWrite' isn't a lowerCamelCase identifier.

lib/antlr4.dart:30:6

   ╷
30 │ void TEST_platformStdoutWrite(Object? object) => stdoutWrite(object);
   │      ^^^^^^^^^^^^^^^^^^^^^^^^
   ╵

To reproduce make sure you are using the lints_core and run dart analyze lib/antlr4.dart

INFO: The variable name 'INVALID_ALT_NUMBER' isn't a lowerCamelCase identifier.

lib/src/atn/src/atn.dart:17:16

   ╷
17 │   static final INVALID_ALT_NUMBER = 0;
   │                ^^^^^^^^^^^^^^^^^^
   ╵

To reproduce make sure you are using the lints_core and run dart analyze lib/src/atn/src/atn.dart

icon indicating section status
Support up-to-date dependencies
20 / 20icon to trigger folding of the section

10/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
collection^1.15.01.17.11.17.1
logging^1.0.01.1.11.1.1

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

icon indicating section status
Support sound null safety
20 / 20icon to trigger folding of the section

20/20 points: Package and dependencies are fully migrated to null safety!

Analysed with Pana 0.21.25, Dart 2.19.1.

23
likes
95
pub points
79%
popularity

Publisher

verified publisher iconlingyu.li

New Dart runtime for ANTLR4.

Repository (GitHub)

Documentation

API reference

License

Icon for licenses.unknown (LICENSE)

Dependencies

collection, logging

More

Packages that depend on antlr4