antenna_app 0.4.5 copy "antenna_app: ^0.4.5" to clipboard
antenna_app: ^0.4.5 copied to clipboard

Common implementations for an antenna app.

0
likes
110/ 140
pub points
0%
popularity

We analyzed this package 6 hours ago, and awarded it 110 pub points (of a possible 140):

failed
Follow Dart file conventions
20 / 30trigger folding of the section

0/10 points: Provide a valid pubspec.yaml

The package description is too short.

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: MIT.

failed
Provide documentation
10 / 20trigger folding of the section

10/10 points: 20% or more of the public API has dartdoc comments

386 out of 657 API elements (58.8 %) have documentation comments.

Some symbols that are missing documentation: alerted, alerted.Alerted, alerted.Alerted.Alerted, alerted.Alerted.message, alerted.Alerted.title.

0/10 points: Package has an example

No example found.

See package layout guidelines on how to add an example.

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 3 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ macOS

These platforms are not supported:

Package does not support platform `Windows`.

Because:

  • package:antenna_app/antenna_app.dart that imports:
  • package:antenna_app/plugins/plugins.dart that imports:
  • package:antenna_app/plugins/notification.dart that imports:
  • package:flutter_local_notifications/flutter_local_notifications.dart that declares support for platforms: Android, iOS, Linux, macOS.
Package does not support platform `Linux`.

Because:

  • package:antenna_app/antenna_app.dart that imports:
  • package:antenna_app/events/events.dart that imports:
  • package:antenna_app/events/message_received.dart that imports:
  • package:firebase_messaging/firebase_messaging.dart that declares support for platforms: Android, iOS, macOS, Web.
Package does not support platform `Web`.

Because:

  • package:antenna_app/antenna_app.dart that imports:
  • package:antenna_app/plugins/plugins.dart that imports:
  • package:antenna_app/plugins/notification.dart that imports:
  • package:flutter_local_notifications/flutter_local_notifications.dart that declares support for platforms: Android, iOS, Linux, macOS.

These issues are present but do not affect the score, because they may not originate in your package:

Package does not support platform `Android`.

Because:

  • package:antenna_app/antenna_app.dart that imports:
  • package:antenna_app/plugins/plugins.dart that imports:
  • package:antenna_app/plugins/notification.dart that imports:
  • package:flutter_local_notifications/flutter_local_notifications.dart that imports:
  • package:flutter_local_notifications/src/notification_details.dart that imports:
  • package:flutter_local_notifications_linux/flutter_local_notifications_linux.dart that imports:
  • package:flutter_local_notifications_linux/src/flutter_local_notifications.dart that imports:
  • package:flutter_local_notifications_linux/src/notifications_manager.dart that imports:
  • package:flutter_local_notifications_linux/src/storage.dart that imports:
  • package:flutter_local_notifications_linux/src/platform_info.dart that imports:
  • package:xdg_directories/xdg_directories.dart that declares support for platforms: Linux.
Package does not support platform `iOS`.

Because:

  • package:antenna_app/antenna_app.dart that imports:
  • package:antenna_app/plugins/plugins.dart that imports:
  • package:antenna_app/plugins/notification.dart that imports:
  • package:flutter_local_notifications/flutter_local_notifications.dart that imports:
  • package:flutter_local_notifications/src/notification_details.dart that imports:
  • package:flutter_local_notifications_linux/flutter_local_notifications_linux.dart that imports:
  • package:flutter_local_notifications_linux/src/flutter_local_notifications.dart that imports:
  • package:flutter_local_notifications_linux/src/notifications_manager.dart that imports:
  • package:flutter_local_notifications_linux/src/storage.dart that imports:
  • package:flutter_local_notifications_linux/src/platform_info.dart that imports:
  • package:xdg_directories/xdg_directories.dart that declares support for platforms: Linux.
Package does not support platform `macOS`.

Because:

  • package:antenna_app/antenna_app.dart that imports:
  • package:antenna_app/plugins/plugins.dart that imports:
  • package:antenna_app/plugins/notification.dart that imports:
  • package:flutter_local_notifications/flutter_local_notifications.dart that imports:
  • package:flutter_local_notifications/src/notification_details.dart that imports:
  • package:flutter_local_notifications_linux/flutter_local_notifications_linux.dart that imports:
  • package:flutter_local_notifications_linux/src/flutter_local_notifications.dart that imports:
  • package:flutter_local_notifications_linux/src/notifications_manager.dart that imports:
  • package:flutter_local_notifications_linux/src/storage.dart that imports:
  • package:flutter_local_notifications_linux/src/platform_info.dart that imports:
  • package:xdg_directories/xdg_directories.dart that declares support for platforms: Linux.
OK
Pass static analysis
50 / 50trigger folding of the section

50/50 points: code has no errors, warnings, lints, or formatting issues

failed
Support up-to-date dependencies
10 / 20trigger folding of the section

0/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
antenna ^1.3.1 1.3.1 1.3.1
firebase_analytics ^10.0.6 10.10.6 10.10.6
firebase_core ^2.3.0 2.31.1 2.31.1
firebase_messaging ^14.1.1 14.9.3 14.9.3
flutter flutter 0.0.0 0.0.0
flutter_dotenv ^5.0.2 5.1.0 5.1.0
flutter_local_notifications ^12.0.4 12.0.4 17.1.2
flutter_secure_storage ^6.0.0 6.1.0 9.2.1
http ^0.13.5 0.13.6 1.2.1
http_parser ^4.0.2 4.0.2 4.0.2
intl ^0.18.0 0.18.1 0.19.0
Transitive dependencies
Package Constraint Compatible Latest
_flutterfire_internals - 1.3.34 1.3.34
args - 2.5.0 2.5.0
async - 2.11.0 2.11.0
boolean_selector - 2.1.1 2.1.1
characters - 1.3.0 1.3.0
clock - 1.1.1 1.1.1
collection - 1.18.0 1.18.0
dbus - 0.7.10 0.7.10
fake_async - 1.3.1 1.3.1
ffi - 2.1.2 2.1.2
file - 6.1.4 7.0.0
firebase_analytics_platform_interface - 3.10.7 3.10.7
firebase_analytics_web - 0.5.7+6 0.5.7+6
firebase_core_platform_interface - 5.0.0 5.0.0
firebase_core_web - 2.17.0 2.17.0
firebase_messaging_platform_interface - 4.5.36 4.5.36
firebase_messaging_web - 3.8.6 3.8.6
flutter_local_notifications_linux - 2.0.0 4.0.0+1
flutter_local_notifications_platform_interface - 6.0.0 7.1.0
flutter_secure_storage_linux - 1.2.1 1.2.1
flutter_secure_storage_macos - 1.1.2 3.1.1
flutter_secure_storage_platform_interface - 1.1.2 1.1.2
flutter_secure_storage_web - 1.2.1 1.2.1
flutter_secure_storage_windows - 1.1.3 3.1.2
flutter_test - 0.0.0 0.0.0
flutter_web_plugins - 0.0.0 0.0.0
js - 0.6.7 0.7.1
leak_tracker - 10.0.4 10.0.5
leak_tracker_flutter_testing - 3.0.3 3.0.5
leak_tracker_testing - 3.0.1 3.0.1
matcher - 0.12.16+1 0.12.16+1
material_color_utilities - 0.8.0 0.11.1
meta - 1.12.0 1.15.0
path - 1.9.0 1.9.0
petitparser - 6.0.2 6.0.2
platform - 3.1.4 3.1.4
plugin_platform_interface - 2.1.8 2.1.8
process - 4.2.4 5.0.2
rxdart - 0.27.7 0.27.7
sky_engine - 0.0.99 0.0.99
source_span - 1.10.0 1.10.0
stack_trace - 1.11.1 1.11.1
stream_channel - 2.1.2 2.1.2
string_scanner - 1.2.0 1.2.0
term_glyph - 1.2.1 1.2.1
test_api - 0.7.0 0.7.1
timezone - 0.9.3 0.9.3
typed_data - 1.3.2 1.3.2
vector_math - 2.1.4 2.1.4
vm_service - 14.2.1 14.2.2
web - 0.5.1 0.5.1
xdg_directories - 0.2.0+3 1.0.4
xml - 6.5.0 6.5.0

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

Found 4 issues. Showing the first 2:

The constraint `^12.0.4` on flutter_local_notifications does not support the stable version `13.0.0`.

Try running dart pub upgrade --major-versions flutter_local_notifications to update the constraint.

The constraint `^6.0.0` on flutter_secure_storage does not support the stable version `7.0.0`.

Try running dart pub upgrade --major-versions flutter_secure_storage to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analyzed with Pana 0.22.3, Flutter 3.22.0, Dart 3.4.0.

Check the analysis log for details.