animated_size_and_fade 4.0.0 copy "animated_size_and_fade: ^4.0.0" to clipboard
animated_size_and_fade: ^4.0.0 copied to clipboard

Does a fade and size transition between widgets of different heights. Also used to show/hide a widget.

193
likes
160/ 160
pub points
95%
popularity

We analyzed this package 2 days ago, and awarded it 160 pub points (of a possible 160):

OK
Follow Dart file conventions
30 / 30trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: BSD-2-Clause.

OK
Provide documentation
20 / 20trigger folding of the section

10/10 points: 20% or more of the public API has dartdoc comments

3 out of 12 API elements (25.0 %) have documentation comments.

Some symbols that are missing documentation: animated_size_and_fade, animated_size_and_fade.AnimatedSizeAndFade.alignment, animated_size_and_fade.AnimatedSizeAndFade.child, animated_size_and_fade.AnimatedSizeAndFade.fadeDuration, animated_size_and_fade.AnimatedSizeAndFade.fadeInCurve.

10/10 points: Package has an example

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 6 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ Windows
  • ✓ Linux
  • ✓ macOS
  • ✓ Web
OK
Pass static analysis
50 / 50trigger folding of the section

50/50 points: code has no errors, warnings, lints, or formatting issues

OK
Support up-to-date dependencies
40 / 40trigger folding of the section

10/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
flutter flutter 0.0.0 0.0.0
Transitive dependencies
Package Constraint Compatible Latest
characters - 1.3.0 1.3.0
collection - 1.18.0 1.19.0
material_color_utilities - 0.8.0 0.12.0
meta - 1.12.0 1.15.0
sky_engine - 0.0.99 0.0.99
vector_math - 2.1.4 2.1.4

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

20/20 points: Compatible with dependency constraint lower bounds

pub downgrade does not expose any static analysis error.

Analyzed with Pana 0.22.6, Flutter 3.22.2, Dart 3.4.3.

Check the analysis log for details.

193
likes
160
pub points
95%
popularity

Publisher

verified publisherglasberg.dev

Does a fade and size transition between widgets of different heights. Also used to show/hide a widget.

Repository (GitHub)
View/report issues

Topics

#transition #animation #widget

Documentation

API reference

License

BSD-2-Clause (LICENSE)

Dependencies

flutter

More

Packages that depend on animated_size_and_fade