angular_recaptcha 0.1.0

  • README.md
  • CHANGELOG.md
  • Installing
  • Versions
  • 28

Angular Recaptcha (Dart) #

How to use #

Add to pubspec.yaml #

# If you are running angular `v5`
angular_recaptcha: ^0.1.0
# If you are still running angular `v4`
# angular_recaptcha: ^0.0.8
# If you are still running angular `v2` or `v3`,
# then you need to use: 
# angular_recaptcha: "0.0.6"` 

then

pub get

Add to index.html #

Deprecated Adding the script tag is no more necessary

<script src="https://www.google.com/recaptcha/api.js?render=explicit"></script>

Use it #

<angular-recaptcha [(ngModel)]="value" key="YOUR_KEY" auto-render></angular-recaptcha>

Options #

Support ngModel for Form validation.

@Inputs #

  • String size: Support "normal" or "compact"
  • String key: Your sitekey
  • String theme: Support "light" or "dark"
  • String type: Support "image" or "audio"
  • bool autoRender: will render the captchat automatically when ready
  • String tabindex

@Outputs #

  • expire: notify when the token is expired, we also set value to null

Getter #

  • value: get the value of the captcha

Functions #

  • render(): manually render the captcha
  • reset(): manually reset the captcha

More documentations

More #

import 'package:angular/angular.dart';
import 'package:angular_recaptcha/angular_recaptcha.dart';

@Component(
    selector: 'app',
    template: '''
        <angular-recaptcha [(ngModel)]="value" key="YOUR_KEY" [(ngModel)]="value" auto-render></angular-recaptcha>
        ''',
    directives: const [AngularRecaptcha, formDirectives ]
)
class AppComponent {
  String value;
}

0.0.10 #

  • Deprecated

    • Adding the script tag is no more necessary
  • Breaking Changes

    • num render() is now returning a Future, Future<num> render()

0.0.9 #

  • Add documentation
  • fix ddc
  • Breaking Changes
    • If you want to use ngModel you have to import formDirectives from angular_forms

0.0.8 #

  • update value when expire

0.0.7 #

  • Upgraded to angular v4.0.0
  • Added Changelog

0.0.1 #

  • Initial version

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  angular_recaptcha: ^0.1.0

2. Install it

You can install packages from the command line:

with pub:


$ pub get

Alternatively, your editor might support pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:angular_recaptcha/angular_recaptcha.dart';
  
Version Uploaded Documentation Archive
0.1.3 Aug 7, 2018 Go to the documentation of angular_recaptcha 0.1.3 Download angular_recaptcha 0.1.3 archive
0.1.2 May 3, 2018 Go to the documentation of angular_recaptcha 0.1.2 Download angular_recaptcha 0.1.2 archive
0.1.0 Apr 24, 2018 Go to the documentation of angular_recaptcha 0.1.0 Download angular_recaptcha 0.1.0 archive
0.0.10 Dec 28, 2017 Go to the documentation of angular_recaptcha 0.0.10 Download angular_recaptcha 0.0.10 archive
0.0.9 Dec 7, 2017 Go to the documentation of angular_recaptcha 0.0.9 Download angular_recaptcha 0.0.9 archive
0.0.8 Sep 21, 2017 Go to the documentation of angular_recaptcha 0.0.8 Download angular_recaptcha 0.0.8 archive
0.0.7 Jul 12, 2017 Go to the documentation of angular_recaptcha 0.0.7 Download angular_recaptcha 0.0.7 archive
0.0.6 May 19, 2017 Go to the documentation of angular_recaptcha 0.0.6 Download angular_recaptcha 0.0.6 archive
0.0.5 Mar 16, 2017 Go to the documentation of angular_recaptcha 0.0.5 Download angular_recaptcha 0.0.5 archive
0.0.4 Feb 12, 2017 Go to the documentation of angular_recaptcha 0.0.4 Download angular_recaptcha 0.0.4 archive

All 13 versions...

Popularity:
Describes how popular the package is relative to other packages. [more]
57
Health:
Code health derived from static analysis. [more]
--
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
--
Overall:
Weighted score of the above. [more]
28
Learn more about scoring.

The package version is not analyzed, because it does not support Dart 2. Until this is resolved, the package will receive a health and maintenance score of 0.

Analysis issues and suggestions

Support Dart 2 in pubspec.yaml.

The SDK constraint in pubspec.yaml doesn't allow the Dart 2.0.0 release. For information about upgrading it to be Dart 2 compatible, please see https://dart.dev/dart-2#migration.

Maintenance issues and suggestions

Make sure dartdoc successfully runs on your package's source files. (-10 points)

Dependencies were not resolved.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.0.0-dev.46.0 <2.0.0