angel_static 2.1.3+2
angel_static: ^2.1.3+2 copied to clipboard

Dart native
Flutter Android iOS Linux macOS Windows

Static server middleware for Angel. Also capable of serving Range responses.

2
likes
100 / 110
pub points
69 %
popularity

We analyzed this package on Mar 4, 2021, and awarded it 100 pub points (of a possible 110):

Follow Dart file conventions
20 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
20 / 20

10/10 points: Package has an example

  • Found example at: example/main.dart

10/10 points: 20% or more of the public API has dartdoc comments

  • 21 out of 31 API elements (67.7 %) have documentation comments.
Support multiple platforms
10 / 20

10/20 points: Supports 1 of 2 possible platforms (native, js)

Consider supporting multiple platforms:

Package not compatible with runtime js

Because:

  • package:angel_static/angel_static.dart that imports:
  • package:angel_static/src/virtual_directory.dart that imports:
  • package:range_header/range_header.dart that imports:
  • package:range_header/src/converter.dart that imports:
  • dart:io
Pass static analysis
30 / 30

30/30 points: code has no errors, warnings, lints, or formatting issues

Support up-to-date dependencies
20 / 20

10/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
angel_framework^2.0.0-rc.02.1.12.1.1
convert^2.0.02.1.13.0.0
crypto^2.0.02.1.53.0.0
file^5.0.05.2.16.1.0
http_parser^3.0.03.1.44.0.0
path^1.4.21.8.01.8.0
range_header^2.0.02.0.2+22.0.2+2
Transitive dependencies
PackageConstraintCompatibleLatest
angel_container-1.1.01.1.0
angel_http_exception-1.1.01.1.0
angel_model-1.0.31.0.3
angel_route-3.1.0+13.1.0+1
async-2.5.02.5.0
charcode-1.2.01.2.0
clock-1.1.01.1.0
code_buffer-1.0.11.0.1
collection-1.15.01.15.0
combinator-1.1.01.1.0
dart2_constant-1.0.2+dart21.0.2+dart2
http2-1.0.12.0.0
http_server-0.9.8+30.9.8+3
intl-0.17.00.17.0
merge_map-1.0.21.0.2
meta-1.3.01.3.0
mime-0.9.71.0.0
mock_request-1.0.71.0.7
quiver-2.1.53.0.0
quiver_hashcode-2.0.02.0.0
recase-2.0.13.0.1
source_span-1.8.11.8.1
stack_trace-1.10.01.10.0
string_scanner-1.1.01.1.0
term_glyph-1.2.01.2.0
tuple-1.0.31.0.3
typed_data-1.3.01.3.0
uuid-2.2.23.0.1

To reproduce run pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

Found 4 issues. Showing the first 2:

The constraint `^2.0.0` on convert does not support the stable version `3.0.0`, that was published 26 days ago.

When convert is 30 days old, this package will no longer be awarded points in this category.

Try running dart pub upgrade --major-versions convert to update the constraint.

The constraint `^2.0.0` on crypto does not support the stable version `3.0.0`, that was published 29 days ago.

When crypto is 30 days old, this package will no longer be awarded points in this category.

Try running dart pub upgrade --major-versions crypto to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analysed with Pana 0.15.2, Dart 2.12.0.

2
likes
100
pub points
69%
popularity

Publisher

angel-dart.dev

Static server middleware for Angel. Also capable of serving Range responses.

Repository (GitHub)
View/report issues

Documentation

API reference

License

MIT (LICENSE)

Dependencies

angel_framework, convert, crypto, file, http_parser, path, range_header

More

Packages that depend on angel_static