angel_oauth2 2.3.0
angel_oauth2: ^2.3.0 copied to clipboard

Dart native
Flutter Android iOS

A class containing handlers that can be used within Angel to build a spec-compliant OAuth 2.0 server.

0
likes
80 / 110
pub points
46 %
popularity

We analyzed this package on Feb 25, 2021, and awarded it 80 pub points (of a possible 110):

Follow Dart file conventions
20 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
20 / 20

10/10 points: Package has an example

  • Found example at: example/main.dart

10/10 points: 20% or more of the public API has dartdoc comments

  • 54 out of 68 API elements (79.4 %) have documentation comments.
Support multiple platforms
10 / 20

10/20 points: Supports 1 of 2 possible platforms (native, js)

Consider supporting multiple platforms:

Package not compatible with runtime js

Because:

  • package:angel_oauth2/angel_oauth2.dart that imports:
  • package:angel_oauth2/src/server.dart that imports:
  • package:angel_framework/angel_framework.dart that imports:
  • package:angel_framework/src/core/core.dart that imports:
  • package:angel_framework/src/core/service.dart that imports:
  • package:angel_framework/src/core/server.dart that imports:
  • package:angel_framework/src/core/routable.dart that imports:
  • package:angel_framework/src/core/response_context.dart that imports:
  • package:angel_framework/src/core/request_context.dart that imports:
  • package:http_server/http_server.dart that imports:
  • package:http_server/src/http_multipart_form_data.dart that imports:
  • package:http_server/src/http_multipart_form_data_impl.dart that imports:
  • dart:io
Pass static analysis
20 / 30

20/30 points: code has no errors, warnings, lints, or formatting issues

INFO: DO use curly braces for all flow control structures.

lib/src/exception.dart:20:7

   ╷
20 │       m['error_uri'] = errorResponse.uri.toString();
   │       ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
   ╵

To reproduce make sure you are using pedantic and run dartanalyzer lib/src/exception.dart

INFO: DO use curly braces for all flow control structures.

lib/src/server.dart:227:7

    ╷
227 │       queryParameters['expires_in'] = token.expiresIn.toString();
    │       ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
    ╵

To reproduce make sure you are using pedantic and run dartanalyzer lib/src/server.dart

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
angel_framework^2.0.0-rc.02.1.12.1.1
angel_http_exception^1.0.01.1.01.1.0
crypto^2.0.02.1.53.0.0
Transitive dependencies
PackageConstraintCompatibleLatest
angel_container-1.1.01.1.0
angel_model-1.0.31.0.3
angel_route-3.1.0+13.1.0+1
charcode-1.1.31.2.0
code_buffer-1.0.11.0.1
collection-1.14.131.15.0
combinator-1.1.01.1.0
convert-2.1.13.0.0
dart2_constant-1.0.2+dart21.0.2+dart2
file-5.2.16.1.0
http2-1.0.12.0.0
http_parser-3.1.44.0.0
http_server-0.9.8+30.9.8+3
intl-0.16.10.17.0
matcher-0.12.90.12.10
merge_map-1.0.21.0.2
meta-1.2.41.3.0
mime-0.9.71.0.0
mock_request-1.0.71.0.7
path-1.7.01.8.0
quiver-2.1.53.0.0
quiver_hashcode-2.0.02.0.0
recase-2.0.13.0.1
source_span-1.7.01.8.1
stack_trace-1.9.61.10.0
string_scanner-1.0.51.1.0
term_glyph-1.1.01.2.0
tuple-1.0.31.0.3
typed_data-1.2.01.3.0

To reproduce run pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^2.0.0` on crypto does not support the latest published version `3.0.0`

pubspec.yaml:11:11

   ╷
11 │   crypto: ^2.0.0
   │           ^^^^^^
   ╵

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analysed with Pana 0.14.10, Dart 2.10.5.

0
likes
80
pub points
46%
popularity

Publisher

angel-dart.dev

A class containing handlers that can be used within Angel to build a spec-compliant OAuth 2.0 server.

Repository (GitHub)
View/report issues

Documentation

API reference

License

MIT (LICENSE)

Dependencies

angel_framework, angel_http_exception, crypto

More

Packages that depend on angel_oauth2