angel_mustache 2.0.0

Dart native

Mustache view generator for Angel.

0
likes
60 / 110
pub points
33 %
popularity

We analyzed this package on Sep 19, 2020, and awarded it 60 pub points (of a possible 110):

Follow Dart file conventions
10 / 20

0/10 points: Provide a valid pubspec.yaml

The package description is too short.

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
10 / 20

10/10 points: Package has an example

  • Found example at: example/main.dart

0/10 points: 20% or more of the public API has dartdoc comments

  • 0 out of 2 API elements (0.0 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

Support multiple platforms
10 / 20

10/20 points: Supports 1 of 2 possible platforms (native, js)

Consider supporting multiple platforms:

Package not compatible with runtime js

Because:

  • package:angel_mustache/angel_mustache.dart that imports:
  • package:angel_mustache/src/mustache_context.dart that imports:
  • package:file/file.dart that imports:
  • package:file/src/interface.dart that imports:
  • package:file/src/io.dart that imports:
  • dart:io
Pass static analysis
20 / 30

20/30 points: code has no errors, warnings, lints, or formatting issues

Found 16 issues. Showing the first 2:

INFO: Use `=` to separate a named parameter from its default value.

lib/angel_mustache.dart:11:26

   ╷
11 │     {String fileExtension: '.mustache', String partialsPath: './partials'}) {
   │                          ^
   ╵

To reproduce make sure you are using pedantic and run dartanalyzer lib/angel_mustache.dart

INFO: Use `=` to separate a named parameter from its default value.

lib/angel_mustache.dart:11:60

   ╷
11 │     {String fileExtension: '.mustache', String partialsPath: './partials'}) {
   │                                                            ^
   ╵

To reproduce make sure you are using pedantic and run dartanalyzer lib/angel_mustache.dart

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
angel_framework^2.0.0-alpha2.1.12.1.1
file^5.0.05.2.15.2.1
mustache4dart^3.0.0-dev3.0.0-dev.1.02.1.2
path^1.0.01.7.01.7.0
Transitive dependencies
PackageConstraintCompatibleLatest
_fe_analyzer_shared-4.0.09.0.0
analyzer-0.39.100.40.2
angel_container-1.1.01.1.0
angel_http_exception-1.1.01.1.0
angel_model-1.0.31.0.3
angel_route-3.1.0+13.1.0+1
args-1.6.01.6.0
async-2.4.22.4.2
build-1.3.01.4.0
build_config-0.4.20.4.2
build_daemon-2.1.42.1.4
build_resolvers-1.3.91.3.11
build_runner-1.10.01.10.2
build_runner_core-5.2.06.0.1
built_collection-4.3.24.3.2
built_value-7.1.07.1.0
charcode-1.1.31.1.3
checked_yaml-1.0.21.0.2
code_buffer-1.0.11.0.1
code_builder-3.4.13.4.1
collection-1.14.131.14.13
combinator-1.1.01.1.0
convert-2.1.12.1.1
crypto-2.1.52.1.5
csslib-0.16.20.16.2
dart2_constant-1.0.2+dart21.0.2+dart2
dart_style-1.3.61.3.7
fixnum-0.10.110.10.11
glob-1.2.01.2.0
graphs-0.2.00.2.0
html-0.14.0+30.14.0+3
http2-1.0.01.0.0
http_multi_server-2.2.02.2.0
http_parser-3.1.43.1.4
http_server-0.9.8+30.9.8+3
intl-0.16.10.16.1
io-0.3.40.3.4
js-0.6.20.6.2
json_annotation-3.0.13.0.1
logging-0.11.40.11.4
matcher-0.12.90.12.9
merge_map-1.0.21.0.2
meta-1.2.31.2.3
mime-0.9.70.9.7
mock_request-1.0.71.0.7
node_interop-1.1.11.1.1
node_io-1.1.11.1.1
package_config-1.9.31.9.3
pedantic-1.9.21.9.2
pool-1.4.01.4.0
pub_semver-1.4.41.4.4
pubspec_parse-0.1.50.1.5
quiver-2.1.32.1.3
quiver_hashcode-2.0.02.0.0
recase-2.0.13.0.0
reflectable-2.2.52.2.5
shelf-0.7.90.7.9
shelf_web_socket-0.2.30.2.3
source_span-1.7.01.7.0
stack_trace-1.9.51.9.5
stream_channel-2.0.02.0.0
stream_transform-1.2.01.2.0
string_scanner-1.0.51.0.5
term_glyph-1.1.01.1.0
timing-0.1.1+20.1.1+2
tuple-1.0.31.0.3
typed_data-1.2.01.2.0
uuid-2.2.22.2.2
watcher-0.9.7+150.9.7+15
web_socket_channel-1.1.01.1.0
yaml-2.2.12.2.1

To reproduce run pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^3.0.0-dev` on mustache4dart does not support the latest published version `2.1.2`

pubspec.yaml:11:18

   ╷
11 │   mustache4dart: ^3.0.0-dev
   │                  ^^^^^^^^^^
   ╵

10/10 points: Package supports latest stable Dart and Flutter SDKs