angel_client 2.0.2

Dart native js
Flutter Android iOS web

Support for querying Angel servers in the browser, Flutter, and command-line.

1
likes
90 / 110
pub points
76 %
popularity

We analyzed this package on Aug 14, 2020, and awarded it 90 pub points (of a possible 110):

Follow Dart file conventions
20 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
20 / 20

10/10 points: Package has an example

  • Found example at: example/main.dart

10/10 points: 20% or more of the public API has dartdoc comments

  • 87 out of 121 API elements (71.9 %) have documentation comments.
Support multiple platforms
20 / 20

20/20 points: Supports 2 of 2 possible platforms (native, js)

Pass static analysis
20 / 30

20/30 points: code has no errors, warnings, lints, or formatting issues

Found 70 issues. Showing the first 2:

INFO: Unnecessary new keyword.

lib/angel_client.dart:126:20

    ╷
126 │     final result = new AngelAuthResult();
    │                    ^^^^^^^^^^^^^^^^^^^^^
    ╵

To reproduce make sure you are using pedantic and run dartanalyzer lib/angel_client.dart

INFO: DO use curly braces for all flow control structures.

lib/angel_client.dart:129:7

    ╷
129 │       result._token = data['token'].toString();
    │       ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
    ╵

To reproduce make sure you are using pedantic and run dartanalyzer lib/angel_client.dart

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
angel_http_exception^1.0.01.1.01.1.0
collection^1.0.01.14.131.14.13
http^0.12.00.12.20.12.2
json_god>=2.0.0-beta <3.0.02.0.0-beta+31.0.1
meta^1.0.01.2.21.2.2
path^1.0.01.7.01.7.0
Transitive dependencies
PackageConstraintCompatibleLatest
charcode-1.1.31.1.3
dart2_constant-1.0.2+dart21.0.2+dart2
http_parser-3.1.43.1.4
logging-0.11.40.11.4
source_span-1.7.01.7.0
string_scanner-1.0.51.0.5
term_glyph-1.1.01.1.0
typed_data-1.2.01.2.0

To reproduce run pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `>=2.0.0-beta <3.0.0` on json_god does not support the latest published version `1.0.1`

pubspec.yaml:12:13

   ╷
12 │   json_god: ">=2.0.0-beta <3.0.0"
   │             ^^^^^^^^^^^^^^^^^^^^^
   ╵

10/10 points: Package supports latest stable Dart and Flutter SDKs

1
likes
90
pub points
76%
popularity

Publisher

angel-dart.dev

Support for querying Angel servers in the browser, Flutter, and command-line.

Repository (GitHub)
View/report issues

Documentation

API reference

License

MIT (LICENSE)

Dependencies

angel_http_exception, collection, http, json_god, meta, path

More

Packages that depend on angel_client