analyzer 1.7.2
analyzer: ^1.7.2 copied to clipboard

This package provides a library that performs static analysis of Dart code.

82
likes
90/ 130
pub points
99%
popularity

We analyzed this package on Nov 28, 2021, and awarded it 90 pub points (of a possible 130):

Follow Dart file conventions
20 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
10 / 20

0/10 points: Package has an example

No example found.

See package layout guidelines on how to add an example.

10/10 points: 20% or more of the public API has dartdoc comments

  • 2270 out of 3720 API elements (61.0 %) have documentation comments.
Support multiple platforms
10 / 20

10/20 points: Supports 1 of 2 possible platforms (native, js)

Consider supporting multiple platforms:

Package not compatible with runtime js

Because:

  • package:analyzer/dart/analysis/analysis_context.dart that imports:
  • package:analyzer/src/workspace/workspace.dart that imports:
  • package:analyzer/src/workspace/bazel.dart that imports:
  • package:analyzer/src/workspace/bazel_watcher.dart that imports:
  • package:watcher/watcher.dart that imports:
  • package:watcher/src/file_watcher/polling.dart that imports:
  • package:watcher/src/stat.dart that imports:
  • dart:io
Pass static analysis
20 / 30

20/30 points: code has no errors, warnings, lints, or formatting issues

Found 21 issues. Showing the first 2:

lib/instrumentation/service.dart doesn't match the Dart formatter.

To format your files run: dart format .

lib/src/dart/analysis/feature_set_provider.dart doesn't match the Dart formatter.

To format your files run: dart format .

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

  • Could not run dart pub outdated: dart pub get failed:
OUT:
Resolving dependencies...
ERR:
Because analyzer depends on analyzer_utilities from path which doesn't exist (could not find package analyzer_utilities at "../analyzer_utilities"), version solving failed.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Support sound null safety
20 / 20

20/20 points: Package and dependencies are fully migrated to null safety!

Analysed with Pana 0.21.4, Dart 2.14.4.