amplify_storage_plugin_interface 0.2.5
amplify_storage_plugin_interface: ^0.2.5 copied to clipboard

The platform interface for the storage module of Amplify Flutter.

0
likes
100/ 130
pub points
95%
popularity

We analyzed this package on Oct 16, 2021, and awarded it 100 pub points (of a possible 130):

Follow Dart file conventions
20 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
0 / 20

0/10 points: Package has an example

No example found.

See package layout guidelines on how to add an example.

0/10 points: 20% or more of the public API has dartdoc comments

  • 4 out of 119 API elements (3.4 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

Support multiple platforms
10 / 20

10/20 points: Supports 2 of 3 possible platforms (iOS, Android, Web)

Found 6 issues. Showing the first 2:

Consider supporting multiple platforms:

Package does not support Flutter platform `Web`.

Because:

  • package:amplify_storage_plugin_interface/amplify_storage_plugin_interface.dart that imports:
  • package:amplify_storage_plugin_interface/src/types.dart that imports:
  • package:amplify_storage_plugin_interface/src/Exceptions/StorageException.dart that imports:
  • package:amplify_core/types/exception/AmplifyException.dart that declares support for platforms: Android, iOS.
Pass static analysis
30 / 30

30/30 points: code has no errors, warnings, lints, or formatting issues

Support up-to-date dependencies
20 / 20

10/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
amplify_core0.2.50.2.50.2.5
flutterflutter0.0.00.0.0
meta^1.1.81.7.01.7.0
Transitive dependencies
PackageConstraintCompatibleLatest
characters-1.1.01.2.0
collection-1.15.01.15.0
plugin_platform_interface-2.0.22.0.2
sky_engine-0.0.990.0.99
typed_data-1.3.01.3.0
vector_math-2.1.02.1.1

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Support sound null safety
20 / 20

20/20 points: Package and dependencies are fully migrated to null safety!

Analysed with Pana 0.21.3, Flutter 2.5.2, Dart 2.14.3.

0
likes
100
pub points
95%
popularity

Publisher

aws-amplify.com

The platform interface for the storage module of Amplify Flutter.

Homepage
Repository (GitHub)
View/report issues

Documentation

API reference

License

Apache-2.0 (LICENSE)

Dependencies

amplify_core, flutter, meta

More

Packages that depend on amplify_storage_plugin_interface