amap_map_fluttify 0.9.1+edd4090
amap_map_fluttify: ^0.9.1+edd4090 copied to clipboard

An `Amap` Map Component, Powered By `Fluttify` Engine.

23
likes
65 / 130
pub points
84 %
popularity

We analyzed this package on Jul 15, 2021, and awarded it 65 pub points (of a possible 130):

Follow Dart file conventions
5 / 20

0/10 points: Provide a valid pubspec.yaml

The package description is too short.

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

5/5 points: Provide a valid README.md

0/5 points: Provide a valid CHANGELOG.md

`CHANGELOG.md` contains too many non-ASCII characters.

The site uses English as its primary language. The content of CHANGELOG.md in your package should primarily contain characters used in English.

Provide documentation
20 / 20

10/10 points: Package has an example

  • Found example at: example/lib/main.dart

10/10 points: 20% or more of the public API has dartdoc comments

  • 87 out of 164 API elements (53.0 %) have documentation comments.
Support multiple platforms
10 / 20

10/20 points: Supports 2 of 3 possible platforms (iOS, Android, Web)

Found 6 issues. Showing the first 2:

Consider supporting multiple platforms:

Package does not support Flutter platform Web

Because:

  • package:amap_map_fluttify/amap_map_fluttify.dart that declares support for platforms: Android, iOS
Pass static analysis
20 / 30

20/30 points: code has no errors, warnings, lints, or formatting issues

Found 399 issues. Showing the first 2:

lib/src/android/com/amap/api/mapcore/util/id.g.dart is not formatted according to dartfmt

To format your files run: dartfmt -w .

lib/src/android/com/amap/api/maps/AMap.g.dart is not formatted according to dartfmt

To format your files run: dartfmt -w .

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
amap_core_fluttify^0.2.00.2.4+bb1f0050.14.0
flutterflutter0.0.00.0.0
foundation_fluttify^0.2.00.2.7+10.11.1
url_launcher^5.2.75.7.106.0.9
Transitive dependencies
PackageConstraintCompatibleLatest
characters-1.1.01.1.0
collection-1.15.01.15.0
flutter_web_plugins-0.0.00.0.0
js-0.6.30.6.3
meta-1.3.01.7.0
plugin_platform_interface-1.0.32.0.1
sky_engine-0.0.990.0.99
typed_data-1.3.01.3.0
url_launcher_linux-0.0.1+42.0.0
url_launcher_macos-0.0.1+92.0.0
url_launcher_platform_interface-1.0.92.0.4
url_launcher_web-0.1.5+32.0.1
url_launcher_windows-0.0.1+32.0.0
vector_math-2.1.02.1.0

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

Found 3 issues. Showing the first 2:

The constraint `^0.2.0` on amap_core_fluttify does not support the stable version `0.3.0+e26c0fa`.

Try running dart pub upgrade --major-versions amap_core_fluttify to update the constraint.

The constraint `^0.2.0` on foundation_fluttify does not support the stable version `0.3.0`.

Try running dart pub upgrade --major-versions foundation_fluttify to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Support sound null safety
0 / 20

0/20 points: Package does not opt in to null safety.

Package language version (indicated by the sdk constraint `>=2.2.2 <3.0.0`) is less than 2.12.

Consider migrating.

Analysed with Pana 0.18.2, Flutter 2.2.3, Dart 2.13.4.

23
likes
65
pub points
84%
popularity

Publisher

fluttify.com

An `Amap` Map Component, Powered By `Fluttify` Engine.

Repository (GitHub)
View/report issues

Documentation

API reference

License

Apache 2.0 (LICENSE)

Dependencies

amap_core_fluttify, flutter, foundation_fluttify, url_launcher

More

Packages that depend on amap_map_fluttify