amap_map_fluttify 0.30.1
amap_map_fluttify: ^0.30.1 copied to clipboard

An `Amap` Map Component, Powered By `Fluttify` Compiler, A Dart Bindings Generator For Native SDK.

22
likes
75 / 130
pub points
84 %
popularity

We analyzed this package on Jun 24, 2021, and awarded it 75 pub points (of a possible 130):

Follow Dart file conventions
15 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

0/5 points: Provide a valid CHANGELOG.md

`CHANGELOG.md` contains too many non-ASCII characters.

The site uses English as its primary language. The content of CHANGELOG.md in your package should primarily contain characters used in English.

Provide documentation
20 / 20

10/10 points: Package has an example

  • Found example at: example/lib/main.dart

10/10 points: 20% or more of the public API has dartdoc comments

  • 110 out of 228 API elements (48.2 %) have documentation comments.
Support multiple platforms
10 / 20

10/20 points: Supports 2 of 3 possible platforms (iOS, Android, Web)

Found 6 issues. Showing the first 2:

Consider supporting multiple platforms:

Package does not support Flutter platform Web

Because:

  • package:amap_map_fluttify/amap_map_fluttify.dart that declares support for platforms: Android, iOS
Pass static analysis
20 / 30

20/30 points: code has no errors, warnings, lints, or formatting issues

Found 270 issues. Showing the first 2:

lib/src/android/com/amap/api/maps/AMap.g.dart is not formatted according to dartfmt

To format your files run: dartfmt -w .

lib/src/android/com/amap/api/maps/AMap/CancelableCallback.g.dart is not formatted according to dartfmt

To format your files run: dartfmt -w .

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
amap_core_fluttify^0.14.00.14.00.14.0
amap_location_fluttify^0.20.00.20.00.20.0
amap_search_fluttify^0.16.1+10.16.20.16.2
core_location_fluttify^0.6.00.6.00.6.0
flutterflutter0.0.00.0.0
foundation_fluttify0.11.10.11.10.11.1
uni_map_platform_interface^0.0.110.0.130.5.1
url_launcher^5.4.25.7.106.0.7
Transitive dependencies
PackageConstraintCompatibleLatest
characters-1.1.01.1.0
collection-1.15.01.15.0
flutter_web_plugins-0.0.00.0.0
js-0.6.30.6.3
meta-1.3.01.4.0
plugin_platform_interface-1.0.32.0.0
sky_engine-0.0.990.0.99
typed_data-1.3.01.3.0
url_launcher_linux-0.0.1+42.0.0
url_launcher_macos-0.0.1+92.0.0
url_launcher_platform_interface-1.0.92.0.3
url_launcher_web-0.1.5+32.0.1
url_launcher_windows-0.0.1+32.0.0
vector_math-2.1.02.1.0

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^0.0.11` on uni_map_platform_interface does not support the stable version `0.1.0`.

Try running dart pub upgrade --major-versions uni_map_platform_interface to update the constraint.

The constraint `^5.4.2` on url_launcher does not support the stable version `6.0.0`.

Try running dart pub upgrade --major-versions url_launcher to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Support sound null safety
0 / 20

0/20 points: Package does not opt in to null safety.

Package language version (indicated by the sdk constraint `>=2.6.0 <3.0.0`) is less than 2.12.

Consider migrating.

Analysed with Pana 0.18.2, Flutter 2.2.2, Dart 2.13.3.