amap_map_fluttify 0.17.19+0a5ab5f
amap_map_fluttify: ^0.17.19+0a5ab5f copied to clipboard

An `Amap` Map Component, Powered By `Fluttify` Engine, A Dart Bindings Generator For Native SDK.

23
likes
70/ 130
pub points
85%
popularity

We analyzed this package on Sep 5, 2021, and awarded it 70 pub points (of a possible 130):

Follow Dart file conventions
10 / 20

10/10 points: Provide a valid pubspec.yaml

0/5 points: Provide a valid README.md

Links in `README.md` should be secure. 1 link is insecure.

README.md:10:22

   ╷
10 │ <li>Fluttify系列插件的生成引擎<a href="http://fluttify.com/#/">fluttify.com</a>网站已上线, 欢迎各位来试用, 目前网站仍然处于早期阶段, 如果有什么建议可以在<a href="https://github.com/fluttify-project/fluttify-feedback/issues/new">反馈仓库</a>中提issue.</li>
   │                      ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
   ╵

Use https URLs instead.

0/5 points: Provide a valid CHANGELOG.md

`CHANGELOG.md` contains too many non-ASCII characters.

The site uses English as its primary language. The content of CHANGELOG.md in your package should primarily contain characters used in English.

Provide documentation
20 / 20

10/10 points: Package has an example

  • Found example at: example/lib/main.dart

10/10 points: 20% or more of the public API has dartdoc comments

  • 112 out of 238 API elements (47.1 %) have documentation comments.
Support multiple platforms
10 / 20

10/20 points: Supports 2 of 3 possible platforms (iOS, Android, Web)

Found 6 issues. Showing the first 2:

Consider supporting multiple platforms:

Package does not support Flutter platform `Web`.

Because:

  • package:amap_map_fluttify/amap_map_fluttify.dart that declares support for platforms: Android, iOS.
Pass static analysis
20 / 30

20/30 points: code has no errors, warnings, lints, or formatting issues

Found 394 issues. Showing the first 2:

lib/src/android/com/amap/api/maps/AMap.g.dart doesn't match the Dart formatter.

To format your files run: flutter format .

lib/src/android/com/amap/api/maps/AMap/CancelableCallback.g.dart doesn't match the Dart formatter.

To format your files run: flutter format .

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
amap_core_fluttify^0.5.6+3ebdbdc0.5.6+3ebdbdc0.14.0
flutterflutter0.0.00.0.0
foundation_fluttify^0.4.14+20.4.180.11.1
url_launcher^5.4.25.7.106.0.10
Transitive dependencies
PackageConstraintCompatibleLatest
characters-1.1.01.1.0
collection-1.15.01.15.0
flutter_web_plugins-0.0.00.0.0
js-0.6.30.6.3
meta-1.3.01.7.0
plugin_platform_interface-1.0.32.0.1
sky_engine-0.0.990.0.99
typed_data-1.3.01.3.0
url_launcher_linux-0.0.1+42.0.2
url_launcher_macos-0.0.1+92.0.2
url_launcher_platform_interface-1.0.92.0.4
url_launcher_web-0.1.5+32.0.4
url_launcher_windows-0.0.1+32.0.2
vector_math-2.1.02.1.0

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

Found 3 issues. Showing the first 2:

The constraint `^0.5.6+3ebdbdc` on amap_core_fluttify does not support the stable version `0.6.0+b2681d9`.

Try running dart pub upgrade --major-versions amap_core_fluttify to update the constraint.

The constraint `^0.4.14+2` on foundation_fluttify does not support the stable version `0.5.0`.

Try running dart pub upgrade --major-versions foundation_fluttify to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Support sound null safety
0 / 20

0/20 points: Package does not opt in to null safety.

Package language version (indicated by the sdk constraint `>=2.6.0 <3.0.0`) is less than 2.12.

Consider migrating.

Analysed with Pana 0.20.0, Flutter 2.2.3, Dart 2.13.4.

23
likes
70
pub points
85%
popularity

Publisher

fluttify.com

An `Amap` Map Component, Powered By `Fluttify` Engine, A Dart Bindings Generator For Native SDK.

Repository (GitHub)
View/report issues

Documentation

API reference

License

Apache 2.0 (LICENSE)

Dependencies

amap_core_fluttify, flutter, foundation_fluttify, url_launcher

More

Packages that depend on amap_map_fluttify