altfire_tracker 0.1.1 copy "altfire_tracker: ^0.1.1" to clipboard
altfire_tracker: ^0.1.1 copied to clipboard

altfire_tracker is a package wrapping FlutterFire Analytics and Crashlytics. It was created to make Firebase SDK versioning and methods easier to use. It is recommended to use the various altfire pack [...]

2
likes
130/ 140
pub points
66%
popularity

We analyzed this package 46 hours ago, and awarded it 130 pub points (of a possible 140):

failed
Follow Dart file conventions
20 / 30trigger folding of the section

0/10 points: Provide a valid pubspec.yaml

The package description is too long.

Search engines display only the first part of the description. Try to keep the value of the description field in your package's pubspec.yaml file between 60 and 180 characters.

Issue tracker URL doesn't exist.

At the time of the analysis https://github.com/altive/altfire/issues?q=is%3Aopen+is%3Aissue+label%3Aaltfire_tracker was unreachable. Make sure that the website is reachable via HEAD requests.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: MIT.

OK
Provide documentation
20 / 20trigger folding of the section

10/10 points: 20% or more of the public API has dartdoc comments

35 out of 35 API elements (100.0 %) have documentation comments.

10/10 points: Package has an example

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 3 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ macOS

These platforms are not supported:

Package does not support platform `Windows`.

Because:

  • package:altfire_tracker/altfire_tracker.dart that imports:
  • package:altfire_tracker/src/tracker.dart that imports:
  • package:firebase_crashlytics/firebase_crashlytics.dart that declares support for platforms: Android, iOS, macOS.
Package does not support platform `Linux`.

Because:

  • package:altfire_tracker/altfire_tracker.dart that imports:
  • package:altfire_tracker/src/tracker.dart that imports:
  • package:firebase_crashlytics/firebase_crashlytics.dart that declares support for platforms: Android, iOS, macOS.
Package does not support platform `Web`.

Because:

  • package:altfire_tracker/altfire_tracker.dart that imports:
  • package:altfire_tracker/src/tracker.dart that imports:
  • package:firebase_crashlytics/firebase_crashlytics.dart that declares support for platforms: Android, iOS, macOS.
OK
Pass static analysis
50 / 50trigger folding of the section

50/50 points: code has no errors, warnings, lints, or formatting issues

OK
Support up-to-date dependencies
20 / 20trigger folding of the section

10/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
firebase_analytics ^10.6.3 10.10.2 10.10.2
firebase_crashlytics ^3.4.9 3.5.2 3.5.2
firebase_crashlytics_platform_interface ^3.6.16 3.6.30 3.6.30
flutter flutter 0.0.0 0.0.0
Transitive dependencies
Package Constraint Compatible Latest
_flutterfire_internals - 1.3.30 1.3.30
async - 2.11.0 2.11.0
boolean_selector - 2.1.1 2.1.1
characters - 1.3.0 1.3.0
clock - 1.1.1 1.1.1
collection - 1.18.0 1.18.0
fake_async - 1.3.1 1.3.1
firebase_analytics_platform_interface - 3.10.3 3.10.3
firebase_analytics_web - 0.5.7+2 0.5.7+2
firebase_core - 2.30.0 2.30.0
firebase_core_platform_interface - 5.0.0 5.0.0
firebase_core_web - 2.15.0 2.15.0
flutter_test - 0.0.0 0.0.0
flutter_web_plugins - 0.0.0 0.0.0
leak_tracker - 10.0.0 10.0.5
leak_tracker_flutter_testing - 2.0.1 3.0.5
leak_tracker_testing - 2.0.1 3.0.1
matcher - 0.12.16+1 0.12.16+1
material_color_utilities - 0.8.0 0.11.1
meta - 1.11.0 1.14.0
path - 1.9.0 1.9.0
plugin_platform_interface - 2.1.8 2.1.8
sky_engine - 0.0.99 0.0.99
source_span - 1.10.0 1.10.0
stack_trace - 1.11.1 1.11.1
stream_channel - 2.1.2 2.1.2
string_scanner - 1.2.0 1.2.0
term_glyph - 1.2.1 1.2.1
test_api - 0.6.1 0.7.1
vector_math - 2.1.4 2.1.4
vm_service - 13.0.0 14.2.1
web - 0.5.1 0.5.1

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analyzed with Pana 0.22.3, Flutter 3.19.5, Dart 3.3.3.

Check the analysis log for details.

2
likes
130
pub points
66%
popularity

Publisher

verified publisheraltive.co.jp

altfire_tracker is a package wrapping FlutterFire Analytics and Crashlytics. It was created to make Firebase SDK versioning and methods easier to use. It is recommended to use the various altfire packages as a set.

Homepage
Repository (GitHub)
View/report issues

Documentation

API reference

License

MIT (LICENSE)

Dependencies

firebase_analytics, firebase_crashlytics, firebase_crashlytics_platform_interface, flutter

More

Packages that depend on altfire_tracker