airport 1.0.0+1 copy "airport: ^1.0.0+1" to clipboard
airport: ^1.0.0+1 copied to clipboard

A library to get airports informations.

5
likes
90/ 140
pub points
21%
popularity

We analyzed this package 15 hours ago, and awarded it 90 pub points (of a possible 140):

failed
Follow Dart file conventions
20 / 30trigger folding of the section

0/10 points: Provide a valid pubspec.yaml

The package description is too short.

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: MIT.

failed
Provide documentation
0 / 20trigger folding of the section

0/10 points: 20% or more of the public API has dartdoc comments

0 out of 18 API elements (0.0 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

Some symbols that are missing documentation: airports, airports.Airports, airports.Airports.Airports, airports.Airports.getAirport, main.

0/10 points: Package has an example

No example found.

See package layout guidelines on how to add an example.

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 6 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ Windows
  • ✓ Linux
  • ✓ macOS
  • ✓ Web
partial
Pass static analysis
40 / 50trigger folding of the section

40/50 points: code has no errors, warnings, lints, or formatting issues

INFO: The variable name 'AirportsList' isn't a lowerCamelCase identifier.

lib/airports.dart:10:19

   ╷
10 │     List<Airport> AirportsList = [];
   │                   ^^^^^^^^^^^^
   ╵

To reproduce make sure you are using the lints_core and run dart analyze lib/airports.dart

INFO: An uninitialized variable should have an explicit type annotation.

lib/airports.dart:11:9

   ╷
11 │     var result;
   │         ^^^^^^
   ╵

To reproduce make sure you are using the lints_core and run dart analyze lib/airports.dart

failed
Support up-to-date dependencies
10 / 20trigger folding of the section

0/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
http ^0.13.3 0.13.6 1.2.1
Transitive dependencies
Package Constraint Compatible Latest
async - 2.11.0 2.11.0
collection - 1.18.0 1.18.0
http_parser - 4.0.2 4.0.2
meta - 1.12.0 1.12.0
path - 1.9.0 1.9.0
source_span - 1.10.0 1.10.0
string_scanner - 1.2.0 1.2.0
term_glyph - 1.2.1 1.2.1
typed_data - 1.3.2 1.3.2

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^0.13.3` on http does not support the stable version `1.0.0`.

Try running dart pub upgrade --major-versions http to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analyzed with Pana 0.22.1, Dart 3.3.0.

Check the analysis log for details.

5
likes
90
pub points
21%
popularity

Publisher

unverified uploader

A library to get airports informations.

Repository (GitHub)
View/report issues

Documentation

Documentation
API reference

License

MIT (LICENSE)

Dependencies

http

More

Packages that depend on airport