ai_barcode_web 3.0.2 copy "ai_barcode_web: ^3.0.2" to clipboard
ai_barcode_web: ^3.0.2 copied to clipboard

Platformweb

scan barcode and create barcode 's plugin interface from 'ai_barcode' plugin.

0
likes
120/ 140
pub points
62%
popularity

We analyzed this package 6 days ago, and awarded it 120 pub points (of a possible 140):

failed
Follow Dart file conventions
20 / 30trigger folding of the section

0/10 points: Provide a valid pubspec.yaml

Failed to verify repository URL.

Please provide a valid repository URL in pubspec.yaml, such that:

  • repository can be cloned,
  • a clone of the repository contains a pubspec.yaml, which:,
    • contains name: ai_barcode_web,
    • contains a version property, and,
    • does not contain a publish_to property.

Repository has no matching pubspec.yaml with name: ai_barcode_web.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: BSD-3-Clause.

failed
Provide documentation
10 / 20trigger folding of the section

10/10 points: 20% or more of the public API has dartdoc comments

26 out of 31 API elements (83.9 %) have documentation comments.

Some symbols that are missing documentation: ai_barcode_web, ai_barcode_web.AiBarcodeCreatorWebPlugin.initialValueOfCreator, ai_barcode_web.AiBarcodeCreatorWebPlugin.unsupportedPlatformDescription, ai_barcode_web.AiBarcodeScannerWebPlugin.notifyResultListenerCallback, ai_barcode_web.AiBarcodeScannerWebPlugin.unsupportedPlatformDescription.

0/10 points: Package has an example

No example found.

See package layout guidelines on how to add an example.

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 1 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Web

These platforms are not supported:

Package does not support platform `Android`.

Because:

  • package:ai_barcode_web/ai_barcode_web.dart that declares support for platforms: Web.
Package does not support platform `iOS`.

Because:

  • package:ai_barcode_web/ai_barcode_web.dart that declares support for platforms: Web.
Package does not support platform `Windows`.

Because:

  • package:ai_barcode_web/ai_barcode_web.dart that declares support for platforms: Web.
Package does not support platform `Linux`.

Because:

  • package:ai_barcode_web/ai_barcode_web.dart that declares support for platforms: Web.
Package does not support platform `macOS`.

Because:

  • package:ai_barcode_web/ai_barcode_web.dart that declares support for platforms: Web.

These issues are present but do not affect the score, because they may not originate in your package:

Package not compatible with platform Web

Because:

  • package:ai_barcode_web/ai_barcode_web.dart that imports:
  • package:ai_barcode_web/src/qr_code_scanner_web.dart that imports:
  • package:ai_barcode_web/src/qr_code_scanner_web_impl.dart that imports:
  • package:universal_html/html.dart that imports:
  • package:universal_html/src/_sdk/html.dart that imports:
  • package:universal_html/src/_sdk_html_additions.dart that imports:
  • dart:io
OK
Pass static analysis
50 / 50trigger folding of the section

50/50 points: code has no errors, warnings, lints, or formatting issues

OK
Support up-to-date dependencies
20 / 20trigger folding of the section

10/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
ai_barcode_platform_interface ^3.0.1 3.0.1 3.0.1
flutter flutter 0.0.0 0.0.0
flutter_web_plugins flutter 0.0.0 0.0.0
qr_flutter ^4.0.0 4.1.0 4.1.0
universal_html ^2.0.8 2.2.4 2.2.4
Transitive dependencies
Package Constraint Compatible Latest
async - 2.11.0 2.11.0
characters - 1.3.0 1.3.0
charcode - 1.3.1 1.3.1
collection - 1.18.0 1.18.0
csslib - 1.0.0 1.0.0
html - 0.15.4 0.15.4
material_color_utilities - 0.8.0 0.8.0
meta - 1.11.0 1.12.0
path - 1.9.0 1.9.0
qr - 3.0.1 3.0.1
sky_engine - 0.0.99 0.0.99
source_span - 1.10.0 1.10.0
term_glyph - 1.2.1 1.2.1
typed_data - 1.3.2 1.3.2
universal_io - 2.2.2 2.2.2
vector_math - 2.1.4 2.1.4

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analyzed with Pana 0.22.2, Flutter 3.19.1, Dart 3.3.0.

Check the analysis log for details.

0
likes
120
pub points
62%
popularity

Publisher

unverified uploader

scan barcode and create barcode 's plugin interface from 'ai_barcode' plugin.

Homepage
Repository (GitHub)
View/report issues

Documentation

API reference

License

BSD-3-Clause (LICENSE)

Dependencies

ai_barcode_platform_interface, flutter, flutter_web_plugins, qr_flutter, universal_html

More

Packages that depend on ai_barcode_web