ai_barcode 3.2.7 copy "ai_barcode: ^3.2.7" to clipboard
ai_barcode: ^3.2.7 copied to clipboard

barcode,qrcode,scan,scanning,Barcode generation,Barcode scanning,qrcode,qrcode generation,qrcode creator

139
likes
160/ 160
pub points
90%
popularity

We analyzed this package 28 hours ago, and awarded it 160 pub points (of a possible 160):

OK
Follow Dart file conventions
30 / 30trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: BSD-3-Clause.

OK
Provide documentation
20 / 20trigger folding of the section

10/10 points: 20% or more of the public API has dartdoc comments

15 out of 21 API elements (71.4 %) have documentation comments.

Some symbols that are missing documentation: ai_barcode, ai_barcode.CreatorController.updateValue, ai_barcode.ScannerController.isOpenFlash, ai_barcode.ScannerController.isStartCamera, ai_barcode.ScannerController.isStartCameraPreview.

10/10 points: Package has an example

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 4 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ macOS
  • ✓ Web

These platforms are not supported:

Package does not support platform `Windows`.

Because:

  • package:ai_barcode/ai_barcode.dart that declares support for platforms: Android, iOS, macOS, Web.
Package does not support platform `Linux`.

Because:

  • package:ai_barcode/ai_barcode.dart that declares support for platforms: Android, iOS, macOS, Web.

These issues are present but do not affect the score, because they may not originate in your package:

Package not compatible with platform Web

Because:

  • package:ai_barcode/ai_barcode.dart that imports:
  • package:ai_barcode/src/ai_barcode_widget.dart that imports:
  • dart:io
OK
Pass static analysis
50 / 50trigger folding of the section

50/50 points: code has no errors, warnings, lints, or formatting issues

OK
Support up-to-date dependencies
40 / 40trigger folding of the section

10/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
ai_barcode_platform_interface ^3.0.1 3.0.1 3.0.1
ai_barcode_web ^3.0.2 3.0.2 3.0.2
flutter flutter 0.0.0 0.0.0
Transitive dependencies
Package Constraint Compatible Latest
async - 2.11.0 2.11.0
characters - 1.3.0 1.3.0
charcode - 1.3.1 1.3.1
collection - 1.18.0 1.19.0
csslib - 1.0.0 1.0.0
flutter_web_plugins - 0.0.0 0.0.0
html - 0.15.4 0.15.4
material_color_utilities - 0.8.0 0.12.0
meta - 1.12.0 1.15.0
path - 1.9.0 1.9.0
qr - 3.0.2 3.0.2
qr_flutter - 4.1.0 4.1.0
sky_engine - 0.0.99 0.0.99
source_span - 1.10.0 1.10.0
term_glyph - 1.2.1 1.2.1
typed_data - 1.3.2 1.3.2
universal_html - 2.2.4 2.2.4
universal_io - 2.2.2 2.2.2
vector_math - 2.1.4 2.1.4

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

20/20 points: Compatible with dependency constraint lower bounds

pub downgrade does not expose any static analysis error.

Analyzed with Pana 0.22.9, Flutter 3.22.2, Dart 3.4.3.

Check the analysis log for details.

139
likes
160
pub points
90%
popularity

Publisher

unverified uploader

barcode,qrcode,scan,scanning,Barcode generation,Barcode scanning,qrcode,qrcode generation,qrcode creator

Homepage
Repository (GitHub)
View/report issues

Documentation

API reference

License

BSD-3-Clause (license)

Dependencies

ai_barcode_platform_interface, ai_barcode_web, flutter

More

Packages that depend on ai_barcode