adv_image_picker 3.1.0 copy "adv_image_picker: ^3.1.0" to clipboard
adv_image_picker: ^3.1.0 copied to clipboard

An advanced image picker with our custom UI, depend on AdvCamera (Custom camera with focus and zoom functionality) and ImageList (A native image list view to render image optimally).

9
likes
100/ 140
pub points
53%
popularity

We analyzed this package 3 days ago, and awarded it 100 pub points (of a possible 140):

failed
Follow Dart file conventions
20 / 30trigger folding of the section

0/10 points: Provide a valid pubspec.yaml

The package description is too long.

Search engines display only the first part of the description. Try to keep the value of the description field in your package's pubspec.yaml file between 60 and 180 characters.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: BSD-3-Clause.

partial
Provide documentation
10 / 20trigger folding of the section

0/10 points: 20% or more of the public API has dartdoc comments

6 out of 98 API elements (6.1 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

Some symbols that are missing documentation: adv_image_picker, adv_image_picker.AdvImagePicker, adv_image_picker.AdvImagePicker.AdvImagePicker, adv_image_picker.AdvImagePicker.accentColor, adv_image_picker.AdvImagePicker.cameraFilePrefixName.

10/10 points: Package has an example

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 2 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS

These platforms are not supported:

Package does not support platform `Windows`.

Because:

  • package:adv_image_picker/adv_image_picker.dart that declares support for platforms: Android, iOS.
Package does not support platform `Linux`.

Because:

  • package:adv_image_picker/adv_image_picker.dart that declares support for platforms: Android, iOS.
Package does not support platform `macOS`.

Because:

  • package:adv_image_picker/adv_image_picker.dart that declares support for platforms: Android, iOS.
Package does not support platform `Web`.

Because:

  • package:adv_image_picker/adv_image_picker.dart that declares support for platforms: Android, iOS.
failed
Pass static analysis
30 / 50trigger folding of the section

30/50 points: code has no errors, warnings, lints, or formatting issues

Found 18 issues. Showing the first 2:

WARNING: The parameter type of '==' operators should be non-nullable.

lib/pages/preview.dart:232:17

    ╷
232 │   bool operator ==(dynamic other) {
    │                 ^^
    ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/pages/preview.dart

WARNING: The '!' will have no effect because the receiver can't be null.

lib/plugins/adv_image_picker_plugin.dart:49:29

   ╷
49 │     ServicesBinding.instance!.defaultBinaryMessenger.setMessageHandler(
   │                             ^
   ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/plugins/adv_image_picker_plugin.dart

OK
Support up-to-date dependencies
20 / 20trigger folding of the section

10/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
adv_camera ^3.1.0 3.1.0 3.1.0
flutter flutter 0.0.0 0.0.0
image_list ^3.0.3 3.0.3 3.0.3
path_provider ^2.0.15 2.1.3 2.1.3
platform ^3.1.0 3.1.4 3.1.4
Transitive dependencies
Package Constraint Compatible Latest
characters - 1.3.0 1.3.0
collection - 1.18.0 1.18.0
ffi - 2.1.2 2.1.2
material_color_utilities - 0.8.0 0.11.1
meta - 1.12.0 1.15.0
path - 1.9.0 1.9.0
path_provider_android - 2.2.4 2.2.4
path_provider_foundation - 2.4.0 2.4.0
path_provider_linux - 2.2.1 2.2.1
path_provider_platform_interface - 2.1.2 2.1.2
path_provider_windows - 2.2.1 2.2.1
plugin_platform_interface - 2.1.8 2.1.8
sky_engine - 0.0.99 0.0.99
vector_math - 2.1.4 2.1.4
win32 - 5.5.1 5.5.1
xdg_directories - 1.0.4 1.0.4

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analyzed with Pana 0.22.3, Flutter 3.22.0, Dart 3.4.0.

Check the analysis log for details.

9
likes
100
pub points
53%
popularity

Publisher

unverified uploader

An advanced image picker with our custom UI, depend on AdvCamera (Custom camera with focus and zoom functionality) and ImageList (A native image list view to render image optimally).

Repository (GitHub)
View/report issues

Documentation

API reference

License

BSD-3-Clause (LICENSE)

Dependencies

adv_camera, flutter, image_list, path_provider, platform

More

Packages that depend on adv_image_picker