admob_util 0.1.0
admob_util: ^0.1.0 copied to clipboard

Flutter Android

A flutter plugin to provide AdMob utility.

0
likes
50 / 110
pub points
0 %
popularity

We analyzed this package on Jan 21, 2021, and awarded it 50 pub points (of a possible 110):

Follow Dart file conventions
10 / 20

0/10 points: Provide a valid pubspec.yaml

The package description is too short.

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
10 / 20

10/10 points: Package has an example

  • Found example at: example/lib/main.dart

0/10 points: 20% or more of the public API has dartdoc comments

  • 4 out of 24 API elements (16.7 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

Support multiple platforms
0 / 20

0/20 points: Supports 1 of 3 possible platforms (iOS, Android, Web)

Found 7 issues. Showing the first 2:

Consider supporting multiple platforms:

Package does not support Flutter platform iOS

Because:

  • package:admob_util/admob_util.dart that declares support for platforms: Android
Pass static analysis
20 / 30

20/30 points: code has no errors, warnings, lints, or formatting issues

Found 3 issues. Showing the first 2:

INFO: 'inheritFromWidgetOfExactType' is deprecated and shouldn't be used. Use dependOnInheritedWidgetOfExactType instead. This feature was deprecated after v1.12.1..

lib/simple_banner.dart:56:21

   ╷
56 │     return (context.inheritFromWidgetOfExactType(_BannerStateHolder)
   │                     ^^^^^^^^^^^^^^^^^^^^^^^^^^^^
   ╵

To reproduce make sure you are using pedantic and run flutter analyze lib/simple_banner.dart

INFO: 'await' applied to 'BannerAd', which is not a 'Future'.

lib/simple_banner.dart:121:5

    ╷
121 │     await _bannerAd
    │     ^^^^^
    ╵

To reproduce make sure you are using pedantic and run flutter analyze lib/simple_banner.dart

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
firebase_admob^0.9.3+40.9.3+40.11.0+1
Transitive dependencies
PackageConstraintCompatibleLatest
characters-1.1.0-nullsafety.51.1.0-nullsafety.5
charcode-1.1.31.2.0-nullsafety.3
collection-1.15.0-nullsafety.51.15.0-nullsafety.5
firebase-7.3.38.0.0
firebase_core-0.4.50.7.0
firebase_core_platform_interface-1.0.43.0.1
firebase_core_web-0.1.1+20.2.1+3
http-0.12.20.12.2
http_parser-3.1.43.1.4
js-0.6.3-nullsafety.30.6.3-nullsafety.3
matcher-0.12.90.12.10-nullsafety.3
meta-1.3.0-nullsafety.61.3.0-nullsafety.6
path-1.7.01.8.0-nullsafety.3
pedantic-1.9.21.9.2
platform-2.2.12.2.1
plugin_platform_interface-1.0.31.0.3
quiver-2.1.52.1.5
source_span-1.7.01.8.0-nullsafety.4
stack_trace-1.9.61.10.0-nullsafety.6
string_scanner-1.0.51.1.0-nullsafety.3
term_glyph-1.1.01.2.0-nullsafety.3
typed_data-1.3.0-nullsafety.51.3.0-nullsafety.5
vector_math-2.1.0-nullsafety.52.1.0-nullsafety.5

To reproduce run pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^0.9.3+4` on firebase_admob does not support the latest published version `0.11.0+1`

pubspec.yaml:14:19

   ╷
14 │   firebase_admob: ^0.9.3+4
   │                   ^^^^^^^^
   ╵

10/10 points: Package supports latest stable Dart and Flutter SDKs

0
likes
50
pub points
0%
popularity

A flutter plugin to provide AdMob utility.

Repository (GitHub)
View/report issues

Documentation

API reference

Uploader

contact@ratson.name

License

MIT (LICENSE)

Dependencies

firebase_admob, flutter

More

Packages that depend on admob_util