admob_util 0.0.3

  • Readme
  • Changelog
  • Example
  • Installing
  • 54

admob_util #

A flutter plugin to provide AdMob utility.

Getting Started #

import 'package:admob_util/admob_util.dart';

bool isTestDevice = await AdmobUtil.isTestDevice;

0.0.1 #

0.0.2 #

  • Add AdmobUtil.getSmartBannerSize().
  • Add SimpleBannerAd widget.

0.0.1 #

  • Initial version, Provide AdmobUtil.isTestDevice.

example/README.md

admob_util_example #

Demonstrates how to use the admob_util plugin.

Getting Started #

This project is a starting point for a Flutter application.

A few resources to get you started if this is your first Flutter project:

For help getting started with Flutter, view our online documentation, which offers tutorials, samples, guidance on mobile development, and a full API reference.

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  admob_util: ^0.0.3

2. Install it

You can install packages from the command line:

with Flutter:


$ flutter pub get

Alternatively, your editor might support flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:admob_util/admob_util.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
19
Health:
Code health derived from static analysis. [more]
99
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
72
Overall:
Weighted score of the above. [more]
54
Learn more about scoring.

We analyzed this package on Jan 25, 2020, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.7.0
  • pana: 0.13.4
  • Flutter: 1.12.13+hotfix.5

Health suggestions

Fix lib/simple_banner.dart. (-1 points)

Analysis of lib/simple_banner.dart reported 2 hints:

line 36 col 21: 'inheritFromWidgetOfExactType' is deprecated and shouldn't be used. Use dependOnInheritedWidgetOfExactType instead. This feature was deprecated after v1.12.1..

line 101 col 5: 'await' applied to 'BannerAd', which is not a 'Future'.

Format lib/admob_util.dart.

Run flutter format to format lib/admob_util.dart.

Maintenance suggestions

The package description is too short. (-18 points)

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

Package is pre-v0.1 release. (-10 points)

While nothing is inherently wrong with versions of 0.0.*, it might mean that the author is still experimenting with the general direction of the API.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.1.0 <3.0.0
firebase_admob ^0.9.0 0.9.0+10
flutter 0.0.0
Transitive dependencies
collection 1.14.11 1.14.12
meta 1.1.8
platform 2.2.1
sky_engine 0.0.99
typed_data 1.1.6
vector_math 2.0.8
Dev dependencies
flutter_test